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System Requirements

                    
Chapter 1

Welcome to SOHO Contacts

SOHO Contacts is the most powerful contact manager for Mac OS X. Use it to manage relationships with your 
clients, family, and friends. It supports all the conveniences of a modern contact manager including phone dial-
ing, call logging, automatic relationship links, auto-completion, map generation, iCal event and to-do linking, 
etc. Its flexible interface lets you view your contacts three different ways including a powerful list view that can 
be sorted and filtered. Best of all, your contacts synchronize seamlessly with the Mac OS X Address Book so you 
have access to your contacts throughout your system. Because SOHO Contacts works with the synchronization 
technologies built-in to Mac OS X 10.4 and later, your contacts can also be synchronized to your cell phone or 
P.D.A. using Apple’s iSync application.

SOHO Contacts also makes sharing contacts over a network easy if you’re part of a workgroup. It features ad-
vanced administration so various members of the workgroup can be assigned different levels of access to the con-
tacts. Mobile users can even take shared contacts with them when they disconnect from the network so they 
always have access to the shared information. When they reconnect to the network, all of their changes to the 
shared contacts will automatically synchronize with the master list of shared contacts.

SOHO Contacts is part of the SOHO series of integrated products and is thus part of a larger and more powerful 
solution. For example, SOHO Contacts works seamlessly with SOHO Print Essentials so you can design and 
print professional-looking labels, envelopes, letters, fax covers, invoices, address books, etc. for your contacts. 
Likewise, SOHO Contacts integrates with SOHO Calendars so you can link appointments to shared contacts. 
SOHO Contacts also integrates with SOHO Notes such that any note or call log you attach to a contact appears 
in SOHO Notes so you can manage all of your notes in one place. 

System Requirements
■ Apple Macintosh G3 or higher
■ Mac OS X v10.4.3 or later
■ 60MB of available disk space

Learning to use SOHO Contacts
To learn how to use SOHO Contacts, consult these resources:

User’s Guide

This guide describes the features and shows how to use SOHO Contacts.

Onscreen Help

Tool tips are available for many of the items in the SOHO Contacts window. To see the tool tips, rest the pointer 
over an item for a couple of seconds.

Technical Support

Chronos provides various support options for SOHO Contacts. See http://www.chronosnet.com/Support/in-
dex.html for technical support options.

Web Resources

Go to http://www.chronosnet.com/Products/index.html to get the latest software and updates for SOHO Con-
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tacts.

Upgrade Information
Please visit http://www.chronosnet.com/Support/ to get the latest information on upgrading from Personal or 
Group Organizer to SOHO Contacts.
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Chapter 2

SOHO Integration

SOHO Notes, SOHO Contacts, and SOHO Calendars are all part of an integrated software series designed to 
help you focus on your business. While each product stands on its own and can be used independently of the 
others, they’re crafted to work seamlessly together for unprecedented power and convenience. The purpose of 
this chapter is to introduce important concepts related to the integrated nature of these products.

A Single Database For Notes, Contacts, & Calendars
The SOHO series of products store their notes, contacts, and calendars in a single database. An integrated data-
base offers several benefits:

■ Seamless Linking. Notes, contacts, and calendars can seamlessly be linked to each other without complica-
tions.

■ Persistent Relationships. Since notes, contacts, and calendars all exist in the same database, relationships 
between these objects cannot be broken accidentally or easily. When these object are in separate databases, 
you must be careful to always keep the separate databases together since their contents are tightly related.

■ Portability. Moving a database from one computer to another is easy since notes, contacts, calendars and 
their relationships are all stored in a single database file.

■ Simple Backups. Backing up all your important information is easier because you only have one database 
to manage.

■ Easy Administration. If you’re operating in a multi-user environment, there’s only one database to admin-
ister for notes, contacts, and calendars. This means a single list of user accounts to manage instead of three 
separate lists to keep synchronized. Plus, you can manage note, contact, and calendar access privileges from 
any SOHO Series product.

Single & Multi-User Enabled
SOHO Notes, SOHO Contacts, and SOHO Calendars are designed for both single and multi-user use out of 
the box without any additional software to purchase. This means the software is as equally suited for a user work-
ing individually at home as it is for a workgroup of twenty on an office network. The built-in dual use nature of 
these integrated products offers several benefits:

■ Simple Purchase Decision. There aren’t any complicated decisions to make since it’s the same product for 
a single or multi-user environment. Simply purchase a single-user license for individual use or a volume li-
cense for multi-user use. Suppose, for example, your company has twenty users who wish to use SOHO 
Notes—simply purchase a 20-user pack.

■ Easy, Cost-Efficient Expansion. You can start out using the SOHO series products for individual use and 
expand to multi-user use at any time without complicated conversions, etc. Simply purchase a volume li-
cense once you’re ready. Licenses are additive so if you start out with a single user license and later buy a 5-
user pack, you’ll have licensing for a workgroup of six users.

■ Same Easy-To-Use Interface. Since the same software is used for both single and multi-user use, you’ll use 
the same easy-to-use interface for both. This means expanding from a single-user environment to a multi-
user environment the experience will be the same and familiar.

■ Flexible Configurations. You can mix and match licensing between SOHO series products to meet your 
needs. For example, you can have five SOHO Notes users and thirty SOHO Calendars users accessing the 
same shared database. Further, the five SOHO Notes users don’t necessarily have to be part of the group of 
thirty SOHO Calendars users. Such flexibility lets you decide the needs of your business and purchase ac-
cordingly instead of forcing you to purchase products you don’t need. Of course, the best idea is to purchase 
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the complete SOHO series for all your users so they all have access to best tools!
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Chapter 3

Installation

This chapter will discuss the steps required to install SOHO Contacts in either a single or multi-user environ-
ment. The single user installation is intended for users who will be installing the product for personal use. The 
multi-user installation is intended for workgroups that wish to share information with multiple users over a net-
work while still providing personal use for each user. This chapter will also discuss what gets installed and how 
to uninstall the product.

Installation (Single User)
The single user installation is intended for those users who wish to install the product for personal use.

To install SOHO Contacts for a single user from a disc:

1. Insert the SOHO Contacts disc into your computer’s optical drive and double-click the installer icon.

To install SOHO Contacts for a single user from a download:

1. Open the SOHO Contacts disk image on your desktop and double-click the installer icon.

For a list of items that get installed on the hard disk see What Gets Installed? on page 8.

Installation (Multi-User)
The multi-user installation is intended for workgroups who wish to share information with multiple users over 
a network while still providing personal use for each user.The multi-user installation involves installing SOHO 
Contacts on both a server computer and each client computer. The same installer is used for both the server and 
client computers.

Note: the server should be a computer on the network that is accessible by all the users who will be accessing it. 
The server computer can be any computer whether it’s a dedicate server or the administrator’s personal machine. 
It’s also a good idea to choose a server whose network address is static and won’t be changing.

To install SOHO Contacts on a server and each client machine from a disc:

1. Insert the SOHO Contacts disc into your computer’s optical drive and double-click the installer. Repeat this 
step on the server computer and each client computer.

To install SOHO Contacts on a server and each client machine from a download:

1. Open the SOHO Contacts disk image and double-click the installer. Repeat this step on the server computer 
and each client computer.

Once you have installed SOHO Contacts on the server and client machines, you will need to set up SOHO Con-
tacts for network access, see Get Started (Multi-user Environment) in Chapter Get Started (Multi-user Environ-
ment) on page 12 for more information. For a list of items that get installed on the hard disk see What Gets 
Installed? on page 8.

What Gets Installed?
The SOHO Contacts installer will install the following items on to your hard disk (“~” denotes your home fold-
er).

■ SOHO Contacts. This is the main application. The SOHO Contacts application will be installed into a 
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folder named “SOHO Series” which will be installed in your main Applications folder: /Applications/
SOHO Series

■ Chronos/SOHO Contacts. This folder stores pictures, textures, and other related files and is installed into 
the “Application Support” folder of your home Library folder: ~/Library/Application Support/Chronos/
SOHO Contacts/

■ SOHO Sync. This is a helper application for SOHO Contacts. The SOHO Sync application is installed 
into the “Helper Applications” folder of the “Chronos” folder: ~/Library/Application Support/Chronos/
Helper Applications/

■ ChronosCalendarsService. This is a helper application for SOHO Contacts. The ChronosCalendarsService 
application is installed into the “Helper Applications” folder of the “Chronos” folder: ~/Library/Application 
Support/Chronos/Helper Applications/

■ ChronosNotesCM.plugin. This is the SOHO Notes contextual menu plugin file and it is installed into the 
“Contextual Menu Items” folder of the “Application Support” folder of your home Library folder: ~/Li-
brary/Contextual Menu Items/ChronosNotesCM.plugin

■ ChronosNotesService. This is a helper application for SOHO Notes. The ChronosNotesService application 
is installed into the “Services” folder of your home Library folder: ~/Library/Services/ChronosNotesService

■ ChronosNotesConduit. This is the conduit that synchronizes notes between SOHO Notes and a Palm 
handheld. The ChronosNotesConduit is installed in the Conduits folder: /Library/Application Support/
Palm HotSync/Conduits 

■ ChronosNotes.wdgt. This is the SOHO Notes widget. The widget is installed into the “Widgets” folder of 
your home Library folder: ~/Library/Widgets/ChronosNotes.wdgt

■ OpenBase. This is the database engine SOHO Contacts uses to store your information. The installer places 
files in several locations:
• /Library/OpenBase
• /Library/StartupItems/OpenBase
• /Library/Frameworks/OpenBase…framework
• /Library/Java/Extensions/OpenBaseJDBC.jar
• /Applications/OpenBase

Uninstall
SOHO Contacts and its related files can be uninstalled two different ways: manually or via the installer.

To uninstall SOHO Contacts via the installer:

1. Double-click the installer.

2. Choose Uninstall from the “Easy Install” pop-up menu.

3. Follow the on-screen prompts.

To uninstall SOHO Contacts manually:

The below steps describe how to uninstall of the components related to SOHO Contacts except for the Open-
Base components. Caution must be taken when uninstalling the software since StickyBrain, SOHO Notes, 
SOHO Contacts, and SOHO Calendars share certain installed components as noted. Note: the OpenBase com-
ponents can only be uninstalled using the uninstall option in the SOHO Contacts installer.

1. Delete the “SOHO Contacts” application from the “SOHO Series” folder. This is located in the “Applica-
tions” folder. If you are not using any other SOHO products from Chronos, delete the “SOHO Series” fold-
er.

2. Delete the “Chronos/SOHO Contacts” folder. This is located in the “Application Support” folder of your 
home Library folder.

3. Delete the “ChronosNotesCM.plugin” from the Contextual Menu Items folder of your home Library fold-
er. Do not delete this file if you’ll still be using StickyBrain or SOHO Notes.
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4. Delete the “ChronosNotes.wdgt” from the Widgets folder of your home Library folder. Do not delete this 
file if you’ll still be using StickyBrain or SOHO Notes.

5. Delete the “ChronosNotesService” from the Services folder of your home Library folder. Do not delete this 
file if you’ll still be using StickyBrain or SOHO Notes.

6. Delete the “ChronosNotesConduit” file. This is located in the directory: /Library/Application Support/
Palm HotSync/Conduits/. Do not delete this file if you’ll still be using StickyBrain or SOHO Notes.

7. Delete the “SOHO Sync” from the “Helper Applications” folder of the “Chronos” folder: ~/Library/Appli-
cation Support/Chronos/Helper Applications/. Do not delete this file if you’ll still be using SOHO Notes, 
SOHO Contacts, or SOHO Calendars.

8. Delete the “ChronosCalendarsService” from the “Helper Applications” folder of the “Chronos” folder: ~/
Library/Application Support/Chronos/Helper Applications/. Do not delete this file if you’ll still be using 
SOHO Notes, SOHO Contacts, or SOHO Calendars.

9. Delete the “com.chronos.SOHONotes.plist” file. This file is located in the “Preferences” folder of your 
home Library folder.

10. Delete the “com.chronos.ChronosNotesService.plist” file. This file is located in the “Preferences” folder of 
your home Library folder.

11. Delete the “ChronosNotesService.bundle” file. This file is located in the “Services” folder of your home Li-
brary folder.
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Get Started (Single-user Environment)

The purpose of this chapter is to show you how to get started with SOHO Notes, SOHO Contacts, or SOHO 
Calendars in a single-user environment depending upon which product(s) you own.

Personal Database
Each user always has a “personal” database on his/her machine in which his/her personal notes, contacts, and 
calendars are stored. The personal database is automatically created the first time SOHO Notes, SOHO Con-
tacts, or SOHO Calendars is launched. This database is called “Chronos_username.db” and is always stored on 
the user’s local hard disk. Information in a personal database cannot be shared with others.

Get Started
To start working with notes:

1. Launch SOHO Notes. A collection of default folders in your personal database will appear in the folders 
region. You can add notes to these folders or create your own folders.

To start working with contacts 

1. Launch SOHO Contacts. SOHO Contacts will automatically synchronize with the Mac OS X Address 
Book and your contacts from the Address Book will start appearing in SOHO Contacts. This may take any-
where from a few seconds to a few minutes depending upon how many contacts you have. 

To start working with calendars:

1. Launch Apple’s iCal. You will not need to use SOHO Calendars since it is primarily used to set up shared 
calendars for a multi-user environment. Instead, you can simply use iCal to view and edit the calendar in-
formation stored in your personal database. The calendar information in your personal database is automat-
ically synchronized with iCal which means you can attach events/tasks to contacts in SOHO Contacts and 
these events/tasks will automatically appear in iCal.

To print business documents:

1. Launch SOHO Print Essentials.

2. OR Launch SOHO Contacts and choose Print > Labels, Envelopes, Fax Covers, etc. to print the documents 
of your choice for the currently selected contacts.
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Chapter 5

Get Started (Multi-user Environment)

The purpose of this chapter is to show you how to set up SOHO Notes, SOHO Calendars, or SOHO Contacts 
in a multi-user environment. This chapter is intended for both administrators and end users. It’s important to 
remember that each of these applications can store their information in the same database. In other words, a da-
tabase can contain notes, calendars, and contacts. This allows for seamless integration between these products 
and a great user experience for your workgroup. For example, notes linked to a contact will appear in both 
SOHO Notes and SOHO Contacts. Although these applications are integrated, they can still be used on their 
own independent of one another. 

The setup for each of these applications in a network environment is the same. This chapter will therefore de-
scribe the setup process for all three products. Plus, there’s a good chance that if you’re setting up one SOHO 
series product, you might be setting up the others as well.

SOHO Notes, SOHO Calendars, and SOHO Contacts are multi-user applications which means a few things:

■ Note, calendar, and contact information can be stored for more than one user in a single database.
■ Multiple users can access the same database simultaneously.
■ Multiple databases can be created on a shared computer.
■ Access privileges can be applied to restrict access to notes, calendars, and contacts on a per user basis.

Personal Database Versus Shared Databases
Each user always has a “personal” database on his/her machine in which his/her personal notes, contacts, and 
calendars are stored. The personal database is automatically created the first time SOHO Notes, SOHO Con-
tacts, or SOHO Calendars is launched. This database is called “Chronos_username.db” and is always stored on 
the user’s local hard disk. Information in a personal database cannot be shared with others.

A “shared” database, on the other hand, is created by an administrator on a shared server. The server should be 
a computer on the network that is accessible by all the users who will be accessing it. The server computer can 
be any computer whether it’s a dedicate server or the administrator’s personal machine. It’s also a good idea to 
choose a server whose network address is static and won’t be changing.

Set up Your Server (Administrators)
This section will discuss the steps, you the administrator, will need to perform to set up network access for a 
SOHO series product. This section assumes you have already installed the SOHO software on the server and 
each of the clients. We highly suggest you read the entire section before getting started. This will help you to 
understand the setup process a little better.

Develop a Game Plan

Setting up SOHO Contacts in multi-user environment is straightforward and simple. A little pre-thinking and 
planning will, however, will make the task even easier and less time-consuming. Below are some questions that 
will help you gain insight into the needs of your organization. Your answers will form the basis of your game plan 
and will be used in future installation and setup steps.

■ List all the people including yourself who will be using SOHO Contacts. You will be creating a user account 
for each of these individuals.

■ Which computer will be used as the designated server?
■ If you’re setting up SOHO Notes, make a list of folders you will want users to store shared notes in. For 
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Set up Your Server (Administrators)
example, you might create a folder for each department in your organization with sub-folders for projects 
each department is working on.
• Next to each folder, list each user who will need access to it. For example, you might want John, Susan, 

and Jennifer to have access to the Marketing Department folder.
• Next to each user name, indicate whether you want the user to have read, write, or read & write access 

to the notes in the folder. For example, you might give John read-only access to the folder while Susan 
and Jennifer have full read/write access.

■ If you’re setting up SOHO Contacts, write down which users you want to have read and read/write access 
to the contacts in the database.

■ If you’re setting up SOHO Calendars, make a list of calendars you will want users to store events and to-dos 
in. For example, you might create calendars for each department in your organization.
• Next to each calendar, list each user who will need access to it. For example, you might want only John 

and Jennifer to have access to the Marketing Department calendar.
• Next to each user name, indicate whether you want the user to have read, write, or read & write access 

to the calendar. For example, you might give John read-only access to the folder while Jennifer has full 
read/write access.

The following is an example game plan:

User Accounts: Sam, Jennifer, Mark, John

Server Computer: G5 Server (192.168.0.1)

Note Folders: Marketing (John—read, Susan—read/write, Jennifer—read/write); Human Resources 
(Sam—read/write, Mark—read/write)

Contact Privileges: Sam—read, Jennifer—read/write, Mark—none, John—read

Calendar Privileges: Marketing (John—read, Jennifer—read/write); Human Resources (Sam—read/write, 
Mark—read/write)

Configure Server Software

The SOHO series products use a commercial database system called OpenBase to store information in. Open-
Base is automatically installed on both the client and server computers as part of the installation process. In order 
for users to access a shared database on a server, you will need to configure OpenBase on the server to allow net-
work access. You don’t need to do this on the client computers since they won’t be accepting external access. If 
you have firewall software running on the server computer, you will need to open up certain ports for OpenBase.

To configure OpenBase for network access:

You configure OpenBase using the OpenBase Manager application which is automatically installed for you.

1. Move to your server computer.

2. Launch the OpenBase Manager application located at /Applications/OpenBase/

3. Choose OpenBaseManager > Local Host Settings.

4. Enable Network Access Allowed. This will allow client machines to connect to shared databases on the server 
computer.

5. OPTIONAL. Click the Read Password Not Secure button to set a read password. If a Read password is set, 
only authorized users may connect to shared databases on the server computer. 

6. OPTIONAL. Click the Host Password Not Secure button to set a host password. If a Host password is set, 
only authorized users may create and delete shared databases on the server computer.

If you need to remove the Read or Host password, click the Read Password Secured or Host Password Secured 
button and leave Password and Verify fields blank and click the Continue button.
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To open ports in the firewall on the server computer:

If you have firewall software running on the server computer, you will need to open up certain ports in the fire-
wall to allow client computers to access the shared database on the server computer. This only needs to be done 
on the server, not the client computer. Open the following ports in your firewall software on the server:

■ 20221 and 20222. OpenBase uses these ports for getting the information needed to connect to OpenBase 
databases by name. 

■ 20223 through 20300. OpenBase uses this range of ports for database ports. Each database will run on its 
own port.

Please consult the help resources of your firewall software for information on opening and closing ports.

Set up Shared Databases (Administrators)
This section will describe how to create and configure shared databases. It assumes you have a game plan in place 
as discussed in the previous section.

Database Manager

The Database Manager is where you will create and delete shared databases, set up user accounts, and assign ac-
cess privileges. The following sections will discuss each of these tasks in detail. This section will show you how 
to access the Database Manager for administrators.

To access the Database Manager for administrators:

1. Launch SOHO Contacts.

2. Choose File > Manage Databases. The Database Manager window will appear.

3. Click the Administrator button to see the administrator options.

Create/Delete Shared Databases

This section will show you how to create and delete shared databases on the server. You do not need to be at the 
server computer in order to do this. You can do this from any client computer.

To create a shared database:

1. Choose File > Manage Databases and click Administrator.

2. Select New Database from the Database pop-up menu. The New Database window will appear.

3. Enter the server address of the computer that you want the database to be created on. The server address can 
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be in the form of 192.168.0.1, http://www.chronosnet.com, or some-name-power-mac-g5.local. Use the 
server name “localhost” or “127.0.0.1” if you want to create the database on the computer you’re sitting at.

4. Enter a database name of your choosing.

5. Enter the name for the admin account. The admin account will be the account that is used to administer 
the database. Since you’re the admin, you can use your own name or other name of your choosing. There 
can only be one admin account.

6. Enter a password for the admin account. You MUST remember this password. If you forget this password, 
you will not be able to reset it. A fee-based password recovery service is the only way to recover your password 
if you lose it. Visit http://www.chronosnet.com/Support/ for more information.

7. Re-confirm the password you typed in the previous step.

8.  Click Create to create the database.

The database will be created on the server computer you specified. The database will be listed in the Database 
pop-up menu so you can add user accounts and assign access privileges.

To delete a database:

1. Choose File > Manage Databases and click Administrator.

2. Select the database you wish to delete from the Database pop-up menu. If the database is not listed in the 
pop-up menu, then select Open Database from the pop-up menu and open the database. Be sure to log in 
using your administrator name and password.

3. Select Delete Selected Database from the Database pop-up menu. You’ll be asked to confirm the delete since 
deleting a deleting a database is a permanent operation and cannot be undone.

Set up User Accounts

A user account will need to be set up for each individual that is going to access a shared database. A user account 
consists of a user name and password.

To add a user account:

1. Choose File > Manage Databases and click Administrator.

2. Select a database from the Database pop-up menu. If the database is not listed in the pop-up menu, then 
select Open Database from the pop-up menu and open the database. Be sure to log in using your adminis-
trator name and password.

3. Click Add (+). A new user account will be created in the selected database.

Add/Remove user accounts.

Quickly see a list of user
accounts in a database.

Administer multiple databases
within the Database Manager
window.
Get Started (Multi-user Environment)          15



Set up Shared Databases (Administrators)
4. Type in a user name and password for the user account. Each individual user will be able to change their 
password later, so you may want to use a temporary password when you first create a user account.

Repeat these steps for each user account you need to create.

To edit a user account:

If a user forgets his/her user name or password, you can reset it for them by editing their user account.

1. Choose File > Manage Databases and click Administrator.

2. Select a database from the Database pop-up menu. If the database is not listed in the pop-up menu, then 
select Open Database from the pop-up menu and open the database. Be sure to log in using your adminis-
trator name and password.

3. Double-click the user name or password you wish to edit in the user list.

4. Type in a new user name or password.

To delete a user account:

1. Choose File > Manage Databases and click Administrator.

2. Select a database from the Database pop-up menu. If the database is not listed in the pop-up menu, then 
select Open Database from the pop-up menu and open the database. Be sure to log in using your adminis-
trator name and password.

3. Select the user account in the user list.

4. Click Minus (-).

Assign Access Privileges

Access privileges provide a way to control the information in a database a user has access to. Access can be indi-
vidually controlled for notes, contacts, and calendars. For example, notes are organized by folders, so access priv-
ileges are assigned on a per folder basis for each user account. This gives you flexibility in controlling which 
information users have access to. There are three levels of access that can be granted to a user:

• None. The user does not have any access to the item.
• Read. The user can view the contents of an item, but cannot change it.
• Write. The user can add or modify the contents of an item. It is possible to assign write-only access in 

certain situations. For example, you can give a user write-only access to the Trash folder for notes. This 
means the user can place a note in the Trash, but can’t see the contents of the trash. In this case, you 
can think of a write-only folder as a “drop” folder.

Each item can be assigned a combination of these access privileges. For example, you can give John Read and 
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Write access to a calendar, but only give Susan Read access to the same calendar.

To assign access privileges for notes:

Access privileges for notes are assigned on a per folder basis. There are two default folders in a database: Unfiled 
and Trash. The next section will show you how to create a folder in a shared database.

1. Choose File > Manage Databases and click Administrator.

2. Select a database from the Database pop-up menu. If the database is not listed in the pop-up menu, then 
select Open Database from the pop-up menu and open the database. Be sure to log in using your adminis-
trator name and password.

3. Select a user account from the user list.

4. Select Notes from the Show pop-up menu.

5. Assign access privilege(s) for each folder listed. 

Repeat these steps for each user account.

To create folders in a shared database:

Only the administrator can create a folder in a shared database. You will need to have the shared database open 
in order to create folders in it.

1. Select a shared database in the folder list. The shared databases will be located at the top of the folder list.

2. Choose Folder > New.

3. Type a name for the folder and click OK.

Repeat these steps for each folder you want to create in a shared database.

To assign access privileges to calendars:

Access privileges for calendars are assigned on a per calendar basis. The next section will show you how to create 
a calendar in a shared database.

1. Choose File > Manage Databases and click Administrator.

2. Select a database from the Database pop-up menu. If the database is not listed in the pop-up menu, then 
select Open Database from the pop-up menu and open the database. Be sure to log in using your adminis-
trator name and password.

3. Select a user account from the user list.

4. Select Calendars from the Show pop-up menu.

Assign access privileges to
each item.

Quickly mark all items with
an access privilege.
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5. Select a user account.

6. Assign access privilege(s) for each calendar listed.

Repeat these steps for each user account.

To create calendars in a shared database:

Only the administrator can create a calendar in a shared database.

1. Choose File > Manage Databases and click Administrator.

2. Select a database from the Database pop-up menu. If the database is not listed in the pop-up menu, then 
select Open Database from the pop-up menu and open the database. Be sure to log in using your adminis-
trator name and password.

3. Select Calendars from the Show pop-up menu.

4. Click Add (+) at the bottom of the calendar list.

5. Type a name for the new calendar.

Repeat these steps for each calendar you want to create in a shared database.

To assign access privileges to contacts:

Access privileges for contacts are assigned on an all or nothing basis in a shared database.

1. Choose File > Manage Databases and click Administrator.

2. Select a database from the Database pop-up menu. If the database is not listed in the pop-up menu, then 
select Open Database from the pop-up menu and open the database. Be sure to log in using your adminis-
trator name and password.

3. Select a user account from the user list.

4. Select Contacts from the Show pop-up menu.

5. Assign access privilege(s) for All Contacts.

Repeat these steps for each user account.

Distribute Information to End Users

The end users in your organization will need to know the following information in order to connect to a shared 
database:

■ Account name and password.
■ Name of shared database.
■ Server address.
■ Read password (if one was set).

An example:

User Name: Susan

Password: 1234

Database: CompanyDB

Server Address: 192.168.0.1 or http://www.chronosnet.com

Read Password: 5678
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Shared Database Backups (Administrators)
The administrator of a shared database will need to manually make a backup of it. In order to backup or restore 
a shared database, you need to be at the computer that the shared database is hosted on. Furthermore, you need 
to make sure ALL users are logged off of the shared database before proceeding

To backup a shared database:

1. Launch the OpenBase Manager application: /Applications/OpenBase/

2. Click the Local button and select the shared database in the list.

3. Choose Action > Configure Database.

4. Click the Backup tab.

5. Enable “Create a compressed copy of the database”.

6. Set the Backup Directory and Schedule. We suggest setting the schedule to a time when users will not be 
accessing the shared database.

To undo all recent changes and return to a database backup:

1. Uncompress the backup database by double-clicking it. You’ll end up with a native OpenBase database file.

2. Launch the OpenBase Manager application: /Applications/OpenBase/

3. Click the Local button and select the shared database in the list that you want to restore.

4. Choose Action > Stop Database, and then Action > Delete Database to delete your existing shared database. 
Use caution when performing this step since it will delete the current database so it can be replaced with the 
backup.

5. Drag the native OpenBase database file that was uncompressed to the following directory: /Library/Open-
Base/Databases/

6. In OpenBase Manager select the database in the list. It may take a few minutes before the database shows 
up in the list.

7. Choose Action > Start Database.

Get Started (End Users)
This section will describe how to get started depending upon which SOHO series products you own.

To start working with notes:

1. Launch SOHO Notes. A collection of default folders in your personal database will appear in the folders 
region. You can add notes to these folders or create your own folders.

2. Follow the steps in the next section to connect to one or more shared databases that your administrator cre-
ated.

To start working with contacts 

1. Launch SOHO Contacts. SOHO Contacts will automatically synchronize with the Mac OS X Address 
Book and your contacts from the Address Book will start appearing in SOHO Contacts. This may take any-
where from a few seconds to a few minutes depending upon how many contacts you have.

2. Follow the steps in the next section to connect to one or more shared databases that your administrator cre-
ated.

To start working with calendars:

1. Follow the steps in the next section to connect to one or more shared databases that your administrator cre-
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ated.

2. Launch Apple’s iCal. Both your personal calendars and calendars in shared databases will appear in iCal. You 
can use iCal to view and edit both personal and shared calendar information. You can also attach events/
tasks to contacts in SOHO Contacts and these events/tasks will automatically appear in iCal.

To print business documents:

1. Launch SOHO Print Essentials.

2. OR launch SOHO Contacts and choose Print > Labels, Envelopes, Fax Covers, etc. to print the documents 
of your choice for the currently selected contacts.

Connect to a Shared Database (End Users)
When you first launch SOHO Notes or SOHO Contacts, a personal database will be created on your computer. 
Each subsequent time you launch either product, you’ll automatically be connected to the personal database. 
This database is used to store your personal notes and contacts. Other users will not have access to your personal 
database, nor can you grant them access.

A shared database, on the other hand, is a database where multiple users can share calendar, contact, and note 
information depending on which SOHO series products are being used. This section will provide you, the end 
user, with the necessary information to connect to a shared database.

Database Manager

The Database Manager is where you will open and close shared databases, take shared databases online/offline, 
and change your account password in a shared database. The following sections will discuss each of these tasks 
in detail.

To access the Database Manager for end users:

1. Open SOHO Contacts.

2. Choose File > Manage Databases. The Database Manager window will appear.

3. Click the User button.

Open/Close Shared Databases

This section will show you how to open and close a shared database.

To open a shared database:

The administrator should have provided you with the following information, so you can open a shared database:

■ Your account name and password.
■ Name of shared database.
■ Server address.
■ Read password. The administrator may or may not have set a read password.

Once you have this information you’re ready to open a shared database.

1. Choose File > Manage Databases and click User.

2. Click the Open button. The Open Database window will appear.

3. Enter or choose the server address, database, user name, and password.

4. Click Connect to open the database. Enter the Read password if your administrator set one and click OK. 
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The database will open and appear in the Connected Databases list of the Database Manager window.

5. Enable Require Login in the Connected Databases list if you want SOHO Contacts to ask you for your ac-
count information each time you launch SOHO Contacts. Otherwise, SOHO Contacts will securely store 
your account information in your Keychain and will use it to open the shared database automatically.

6. Close the Database Manager window. If you’re running SOHO Notes, the shared database will appear in 
the folder list. If you’re running SOHO Contacts, the shared database will appear in the Group list. If you’re 
running SOHO Calendars, the calendars that you have been given access to will be created on your com-
puter and will be accessible via Apple’s iCal application. 

To close a shared database:

When you close a shared database, SOHO Contacts will not automatically open it the next time you launch the 
software. You will need to re-open the database manually using the instructions in the previous section.

1. Choose File > Manage Databases and click User.

2. Select the database you wish to close in the Connected Databases list.

3. Click the Close button.

To change the password of your user account:

You can change the password of your user account for a shared database. If you wish to change the user name of 
your account, you will need to contact your administrator to do this.

1. Choose File > Manage Databases and click User.

2. Select the shared database you wish to change the password of your user account.

3. Click the Change Password button.

4. Enter in your current password and click OK.

5. Enter in the new password and then enter it again to confirm it.

6. Click the Change Password button.

Online/Offline Shared Databases (Mobile End Users)
If you have a laptop computer, you understand that you can’t always be connected to the shared database on 
your office network. Yet, you still may want to access and make changes to the notes, contacts, and calendars in 
a shared database while you’re away. Now you can, and it’s easy to do. Simply, take the shared database “offline” 
before you disconnect from the office network and then later bring the shared databases “online” after you’ve 
reconnected to the office network.

When you take a shared database offline, a mirror copy of the shared database is copied to your computer. This 

Check the online/offline
status of a database.

Check to require a login
each time you open the
software.

See a list of connected
databases.
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becomes the “offline” shared database. While you’re away from the office, you can access and make changes to 
the offline database. When you return to the office and bring your offline database online again, changes made 
to the offline database on your computer are synchronized with the online database on the network. It’s that easy.

To take a shared database offline:

When a database is taken offline, a mirror copy of the shared database is saved on your computer so you can 
continue to work on it even when you're not connected to the network.

1. Choose File > Manage Databases and click User.

2. Select the database you wish to take offline. The Status column in the Connected Databases list will show 
you whether you’re currently accessing the online or offline version of the shared database.

3. Click Go Offline.

To take a shared database online:

When you bring a database back online, all of your changes are synchronized with the original online shared da-
tabase on the network.

1. Choose File > Manage Databases and click User.

2. Select the database you wish to bring online. The Status column in the Connected Databases list will show 
you whether you’re currently accessing the online or offline version of the shared database.

3. Click Go Online.

Please note that if a modification to a record has been made in both the offline database and the main shared 
database, the modification in the offline database will overwrite the modification in the main shared database.
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Card and Column View
Chapter 6

Using SOHO Contacts

The purpose of this chapter is to acquaint you with the basics of using SOHO Contacts. The basics include the 
Card and Column view, tabs, and searching.

Card and Column View
When you first launch SOHO Contacts the Card and Column view will be the first window you see.This view 
is primarily used to create, edit, search, and view contacts. This view is comprised of a toolbar, Group and Name 
columns, and a card region. For more information on the Card and Column view and other views available in 
SOHO Contacts, see Contact Views on page 39.

Toolbar

The toolbar at the top of the view provides quick access to frequently used commands.You can choose which 
commands appear in the toolbar and how they are arranged. 

Shared databases will
be listed in the group
column.

Organize your contacts
into groups.

Switch between the
different views.

Quickly search for a
contact.

Attach a note, event,
task, etc. to a contact.

Quickly print a label,
envelope, etc. for a contact.

Zoom in or out on the contact
card to make it bigger or
smaller.

See a summary of a
contact.

The blocks contain
all the pertinent data
for a contact.

Use the tool bar to access
frequently used commands.
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To customize the toolbar:

1. Choose View > Customize Toolbar.

2. Drag items into, out of, or to a new location in the toolbar.

To quickly rearrange a toolbar, hold down the Command key and drag a toolbar item to a new location, or drag 
it out of the toolbar to remove it.

To show or hide the toolbar:

1. Choose View > Show ToolBar or Hide Toolbar.

Group Column

The Group column will display the groups of contacts you have created. Groups are used to organize your con-
tacts: Friends, Family, Co-Workers, etc. Furthermore, the Group column will display any shared databases that 
you are connected to. For more information on shared databases see Personal Database Versus Shared Databases 
in Chapter Get Started (Multi-user Environment) on page 12.

Name Column

The Name column will display the contacts in the selected group or shared database. You can sort the Name 
column, change the size of text used, and change the display order of contact information.

To sort the contacts in the Name column:

1. Choose SOHO Contacts > Preferences, and click the General button.

2. Change the Sort By selection.

To change the size of text used in the Name column:

1. Choose SOHO Contacts > Preferences, and click the General button.

2. Change the List Font Size selection.

To change the display order of contact information:

1. Choose SOHO Contacts > Preferences, and click the General button.

2. Change the Display Name Order selection.

Card Region

The card region is used to display and edit the details of a contact such as its phone number, email addresses, etc. 
These details are grouped into blocks. For more information on blocks see Working With Blocks on page 29.

Tabs
You can open a contact in a tab rather than opening the contact in a separate window or replacing the contents 
of the current window. This allows you to open and view multiple contacts without having to open and manage 
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multiple windows. 

To open a note in a new tab:

When you open a contact in a tab, the tab will appear in the tab bar located below the toolbar. 

1. Choose File > New Tab then select a contact, OR hold down the Option key while selecting a contact.

By default new tabs will automatically be selected. This can be disabled in the Tabs preferences (SOHO Contacts 
> Preferences, and click the Tabs button).

To close a tab:

1. Click the close button on the tab.

To always show the tab bar:

By default the tab bar will only show if there’s at least one tab opened.

1. Choose StickyBrain > Preferences, and click the Tabs button.

2. Select Always show tab bar.

3. Change the Tab Bar Position to where you would like it.

Searching
You can quickly search for a contact or multiple contacts using the Search field in the toolbar. You can also do 
an advanced search, which lets you further refine a search using additional criteria.

To search for a contact or multiple contacts:

1. Click in the Search field in the toolbar.

2. Type the text you want to find. As you type, SOHO Contacts will display the matching contacts.

Use tabs to open multiple
contacts in a single window.
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3. Choose a field from the Search field pop-up menu to specify which fields you want to search in.

To search for a contact using advance search options:

The advance search options let you further refine a search using additional criteria. For example, you can search 
for all the John’s in New York but not in Albany, New York.

1. Choose Edit > Advanced Search. The advanced search window will appear.

2. Add and customize search criteria.

3. Click Search to perform the search.

To clear the advanced search:

You’ll need to clear the advanced search when you want to see all of the contacts of a selected group again.

1. Choose Edit > Clear Advanced Search OR click the Clear Advanced Search button in the Advanced Search 
window.

Select the fields you
want to search in.

Set your search criterion.

Quickly add or remove a search
criterion.
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Chapter 7

Creating and Working with Contacts

The purpose of this chapter is to describe how to create and work with contacts including several unique and 
powerful management features.

Create a Contact
This section will show you how to create a contact and specify where the contact represents and organization. 
When you first launch SOHO Contacts, it will automatically synchronize all of the contacts from Apple’s Ad-
dress Book application to your personal database. Thereafter, contacts will remained synchronized between each 
application. Contacts in shared databases are not synchronized to the Address Book.

Contact vs. Organization

The main difference between a contact and an organization contact is the way each are displayed. If a contact is 
marked as an organization, the Name column will display the organization name of the contact and the Name 
block will list the organization field first. If the contact is not marked as an organization, the Name column will 
display the first and last name of the contact and the Name block will list the name field first. For more infor-
mation on the Name block see Working With Blocks on page 29.

To create a contact:

1. Select a group in the Group column to which the contact will belong.

2. Choose File > New Contact, or click Add (+) the bottom of the Name column.

3. Fill in the contact fields as applicable. For more information on contact fields see Working With Contact 
Fields on page 28.

4. OPTIONAL. Choose File > Save Contact to save the contact. This step is optional because contacts are au-
tomatically saved.

To create an organization:

1. Select a group in the Group column to which the contact will belong.

2. Choose File > New Contact, or click Add (+) the bottom of the Name column.

3. Type the name of the organization in the organization field and mark it as an Organization.

4. Fill in the contact fields as applicable. For more information on contact fields see Working With Contact 
Fields on page 28.

5. OPTIONAL. Choose File > Save Contact to save the contact. This step is optional because contacts are au-
tomatically saved.

Mark if the contact is an
organization.
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To duplicate a contact:

1. Select a contact.

2. Choose Edit > Duplicate.

Create a Group
An easy way to manage your contacts is to organize them into groups. For example, you can create a group named 
“Family” and then add contacts that belong to your family to that group.

To create a group in your personal database:

1. Select My Contacts in the Group column.

1. Choose File > New Group, or click Add (+) the bottom of the Group column.

2. Type a name for the group and press return.

To create a group in a shared database:

1. Select a shared database in the Group column.

2. Choose File > New Group, or click Add (+) the bottom of the Group column.

3. Type a name for the group and press return.

To add contacts to a group:

1. Select contact(s) in the Name column and drag them to a group. Hold down the shift key to select multiple 
contiguous contacts. Hold down the command key to select multiple contacts in a non-contiguous fashion.

Working With Contact Fields
This section will show you how to add, remove and change the label for contact fields. Many contact fields such 
as Name, E-mail, Phone, Address, and URL have a button next to them to performs an action related to that 
field. This section will discuss the actions each of the buttons perform. For example, the button next to an email 
address field, when pressed, will open your default email application and create a new message to the contact.

To add a field:

You can add any number of fields to a contact such as email, phone, address, etc.

1. Click the label of an existing contact field and choose Add (name of field) from the pop-up menu.

To remove a field:

1. Click the label of the field you wish to remove and choose Remove from the pop-up menu.
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To change the label of a field:

1. Click the label of the field you wish to change.

2. Choose a label from the pop-up menu, or select Custom to create a new label.

To use an action button:

When you click the action button next to a contact field such as Name, E-mail, Phone, Address, or URL a certain 
action will be performed. TABLE 1. “Field Button Actions” will list the contact fields that have action buttons 
and their corresponding action. These buttons appear to the left of the field label.

Working With Blocks
Blocks are used to organize contact fields by their related type. For example, all the email addresses for a contact 
will be located in the Email block. This makes it easy to quickly identify the information you’re looking for when 
viewing contacts. This section will show you the basics of blocks, provide information on using each of the dif-
ferent blocks, and describe how to change the visual theme of the blocks.

Block Basics

This section will show you how to add and remove blocks and rearrange the order in which they appear in the 
card region.

To add/remove blocks from the card region:

1. Choose SOHO Contacts > Preferences, and click the Layout button.

TABLE 1. Field Button Actions

Action Button Action

Name The Name button will open a window that will allow you to review how 
the full name was separated into the individual name fields.

E-mail The E-mail button will open the default email application and create a 
new message to the selected contact.

Phone The Phone button will let you choose to dial or send an SMS to the 
selected phone number. For more information on dialing and SMS see 
Incoming/Outgoing Phone Calls on page 32.

Address The Address button will map the address using the Google or 
MapQuest mapping service. To change the default mapping service, 
choose SOHO Contacts > Preferences and click the General button.

URL The URL button will open the default web browser to the selected 
URL.

Relationships The Relationships button will open the linked contact in a new tab.

The E-Mail block will list all the 
email addresses for a contact
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2. Check the blocks you want to add/remove in the “Visible blocks and display order” list.

To rearrange the order in which blocks appear in the card region:

1. Choose SOHO Contacts > Preferences, and click the Layout button.

2. Click and drag a block name to a different position in the list.

To restrict the minimum and maximum number of block columns:

The card region arranges blocks into columns and rows. Most blocks will only occupy a single column, but others 
will occupy two or more columns. You can restrict the minimum and maximum number of block columns the 
card region has. This will give you control over how the blocks appear in the card region.

1. Choose SOHO Contacts > Preferences, and click the Layout button.

2. Type the minimum and maximum number of columns to allow in the card region.

Name Block

The Name block is where you enter a contact’s name, organization, job title, nickname, etc. You can change the 
format and individual fields that appear in the Name block. The Standard format includes a minimal amount of 
name related fields, whereas the Expanded format includes all of the name fields. 

The Standard format includes a single Name field in which you type a contact’s first, last, middle, prefix, suffix, 
and nickname into one field. SOHO Contacts then automatically parses the name you entered and figures out 
how the name should be divided and saved as individual name fields. This combined name field makes it quick 
and easy to enter contact names. You can click the Name action button to confirm how SOHO Contacts divided 
the combined name field if the name you entered is complex. The Expanded format, on the other hand, includes 
a separate field for each of the name related fields.

To set the default format for the Name block:

You can set the default format for the Name block for both a contact and an organization.

1. Choose SOHO Contacts > Preferences, and click the Layout button.

2. Choose a default format from either the People or the Organizations pop-up menu in the Default Name 
block region.

To change the format for the Name block on a contact-by-contact basis:

1. Select a contact.

2. Choose Contact > Name Block Format, and select a format from the menu. This will change the format 
only for the selected contact.

Attachments Block

The Attachments block is used to keep track of items attached to a contact such as notes, incoming/outgoing 

Easily rearrange the order of
blocks.
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calls, incoming/outgoing SMS messages, files, tasks, events, etc. 

To add an attachment:

1. Click Add (+) and choose an item from the menu to attach to the contact. For more information on attach-
ing a note, file, task, or event to a contact see Attachments and Links on page 37. For more information on 
attaching an incoming/outgoing phone call see Incoming/Outgoing Phone Calls on page 32. For more infor-
mation on attaching an SMS message see SMS on page 36.

To delete an attachment:

1. Select an attached item and click Minus (-) to delete it. If the item you’re deleting is attached to other con-
tacts, the item will be detached from the selected contact but the item will not be deleted. If the item you’re 
deleting is only attached to the selected contact, it will be deleted. If you delete a file attachment, the file will 
simply be detached from the selected contact, but the file will not be deleted on disk.

To open an attachment:

1. Double-click an attachment to open it.

To control which attachment are displayed and how they are displayed:

1. Click the Show pop-up menu to filter the attachments by type.

2. Click the Columns pop-up menu to choose the columns to display.

3. Click a column heading to sort on a particular column. Repeat this step to reverse the sort order. A blue 
column heading indicates that the column is being sorted on. The arrow in the column heading will dictate 
whether the column is being sorted in ascending or descending order. 

Keywords Block

The Keywords block is used to assign keywords to contacts. Keywords provide a way to mark a contact with cer-
tain words to help you organize your contacts. You can then use the advanced search to search for contacts based 
on keywords. For more information on the advanced search option see Searching on page 25.

Relationships Block

The Relationships block is used to enter contacts that are somehow related to the selected contact. Related con-
tacts are internally linked to one another automatically for your convenience. For more information on contact 
linking see Attachments and Links on page 37.

Custom Block

The Custom block is used to store additional fields that don’t necessarily fit into one of the other blocks. You 
can store any type of information you would like in a custom field. For example, you may want to store the birth-
place, student ID, or hobby of a contact.

Double-click an attachment to open it.

Select which columns you would
like displayed.

Quickly filter the list of attachments.Add/Delete attachments.
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Address, Phone, E-Mail, URLs, Chat, Notes, and Dates Blocks

Each of these blocks are used to store information related to their block name. For example, the Phone block is 
used to store all the phone numbers for a contact.

Contact Summary

As the name suggests, the Contact Summary shows a brief summary of a contact’s frequently used information. 
You can choose how many lines of information is shown. For example, if you choose to only show one line in 
the Contact Summary, only the contacts name and phone number will be displayed.

To choose how many lines of information are displayed in the Contact Summary:

1. Choose SOHO Contacts > Preferences, and click the Layout button.

2. Select the number of lines you want to display from the Contact Summary pop-up menu.

Themes

Themes provide a way to change the appearance of the blocks. SOHO Contacts comes with many professional-
looking themes so you can choose a look that works best for you.

To change the theme of the blocks:

1. Choose SOHO Contacts > Preferences, and click the Layout button.

2. Choose a theme from the Theme pop-up menu. 

Incoming/Outgoing Phone Calls
SOHO Contacts can dial phone numbers using your modem, a Bluetooth enabled cell phone, or the speaker in 
your computer. If you have Caller ID and a phone call comes in, SOHO Contacts will let you know who’s call-
ing. Furthermore, you can record and log notes for both incoming and outgoing calls. Logged call notes are au-
tomatically attached to the relevant contact. This section will show you how to set up dialing, dial phone 
numbers, format phone numbers, receive phone calls, and use the Outgoing/Incoming Call windows.

Set up Phone Dialing

SOHO Contacts can dial a phone number using your computer’s modem, a Bluetooth enabled cell phone, or 
the speaker in the computer.

■ Modem. The phone number will be dialed using the modem in your computer. Once the number has been 
dialed, you will use a regular phone handset to talk.

■ Cell Phone. The phone number will be dialed using your Bluetooth enabled cell phone. Once the number 
has been dialed, you will use the cell phone to talk. Your computer and cell phone will need to be Bluetooth 
enabled and will need to have been paired together in order for this dialing method to work.

■ Speaker. The phone number will be dialed using the speaker in your computer. You will place a phone hand-
set up to the speaker when the number is being dialed, and the phone handset will recognize the tones and 
dial the phone number. Once the number has been dialed, you will use the phone handset to talk.

To choose the default phone dialer:

1. Choose SOHO Contacts > Preferences, and click the Dialing button.

2. Select a dialing method from the “Default phone dialer” pop-up menu.
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To set up a modem for dialing:

In order to use a modem for dialing you will need to select which modem you want to use, set the initialization 
string, and then enabled the modem.

1. Choose SOHO Contacts > Preferences, and click the Dialing button. All settings for modem dialing will be 
in the Modem section of the Dialing preference page.

2. Select a modem from the “Use this serial port” pop-up menu if you have multiple modems connected to 
your computer.

3. Set the initialization string. The default string should be sufficient for most modems. Only change this set-
ting if you are familiar with modem initialization strings.

To enable a modem for dialing:

You will need to enable the modem for dialing once you have set it up. When you enable a modem for dialing, 
SOHO Contacts will take full control of the modem (other applications on your computer will not be able to 
use the modem).

1. Choose SOHO Contacts > Use Modem. If you want to enable the modem automatically when you use 
SOHO Contacts, choose SOHO Contacts > Preferences, and click the Dialing button and enable “Start 
modem on application startup”.

To set up a Bluetooth cell phone for dialing:

In order to use a cell phone for dialing both your computer and cell phone will need to be Bluetooth enabled. 
Both devices will need to be paired using the Bluetooth pane of System Preferences.

1. Choose SOHO Contacts > Preferences, and click the Dialing button. All settings for Bluetooth dialing will 
be in the Bluetooth section of the Dialing preference page.

2. Click the Choose button to select a Bluetooth enabled cell phone to use.

3. Click “Open Apple Bluetooth Preference Pane” if you need to pair a Bluetooth enable cell phone with your 
computer.

To enable a Bluetooth cell phone for dialing:

You will need to enable your Bluetooth phone for dialing once you have set it up.

1. Choose SOHO Contacts > Use Bluetooth. If you want to enable Bluetooth automatically when you use 
SOHO Contacts, choose SOHO Contacts > Preferences, and click the Dialing button and enable “Start 
Bluetooth on application startup”.

Dial a Phone Number And Log The Call

This section will show you how to dial a phone number and record notes about the phone call.

To dial a phone number and log the call:

1. Select a contact.

2. Click the action button next to a phone number.

Quickly dial a phone number.
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3. Choose “Call Using Default Method” from the pop-up menu, or choose Call from the pop-up menu and 
select a specific call method. For more information on setting the default call method see To choose the default 
phone dialer: on page 32. The Outgoing Call window will appear.

4. Click the Dial button to dial the phone number. For information on using the Outgoing Call window see 
Outgoing/Incoming Call Windows on page 34.

Phone Formatting

Phone numbers can be formatted to reflect the standard for the country you live, the country your contacts live 
in, or certain preference you may have. SOHO Contacts comes with a set of standard formats, but you can easily 
create new formats.

To choose/create a phone format:

1. Choose SOHO Contacts > Preferences, and click Phone button.

2. Select a format from the pop-up menu, or choose Custom to create a new format.

3. Double-click an existing format to edit it, or click the plus button to add a new format. For example: Sup-
pose you want phone numbers to display as this: 1-888-555-7777 Ext.111. To create this format, type the 
following into the format field: #-###-###-#### Ext.###.

Receive Phone Calls

When you receive a phone call, SOHO Contacts will search for a relevant contact using any Caller ID informa-
tion available to it and open an Incoming Call window. The Incoming Call window will display the contact’s 
information and you will be able to log notes about the call. This information will be saved as an Incoming Call 
note attachment for the contact. For more information on the Incoming Call Window see Outgoing/Incoming 
Call Windows on page 34.

In order for this to work, your cell phone or modem will need to support Caller ID (most recent models do). 
You will need to have enabled Bluetooth or Modem for dialing in SOHO Contacts. For more information on 
enabling these two options see Set up Phone Dialing on page 32.

Outgoing/Incoming Call Windows

The Outgoing and Incoming Call windows provide a way to log communication with a contact and attach it to 
the contact. In addition, these windows allow you to keep track of time spent on the phone with the contact 
including the ability to keep track of the billable time.

To open and use the Outgoing Call window:

1. Dial a contact phone number, or click Add (+) in the Attachments block and choose Outgoing Phone Call 
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from pop-up menu. The Outgoing Call window will appear.

2. Click Dial to dial the phone number. When you dial the phone number the Start Time will be filled in.

3. Click Hang-up when the phone call is complete. When you click Hang-up, the End Time and Elapsed Time 
will be filled in.

4. Click Start Billing to start the Billable Time. Click Pause Billing to pause the timer, and click Resume Billing 
to start the timer again.

5. Type a title for the outgoing phone call and enter any applicable notes for the call.

6. The Start Time, End Time, and Billable Time can be edited by clicking in the field you wish to edit.

7. Click Save in the toolbar to save the note, or click Delete to delete the note.The outgoing call note will be 
saved and attached to the contact.

You will be able to access the outgoing call note from the Attachments block. For more information on the At-
tachments block see Working With Blocks in Chapter Creating and Working with Contacts on page 29.

To open and use the Incoming Call window:

1. When an incoming call comes in and SOHO Contacts finds the caller in the database using Caller ID, the 
Incoming Call window will open. You can manually open an incoming call window using by clicking Add 
(+) in the Attachments block and choose Incoming Phone Call from pop-up menu. The Incoming Call win-

Enter in notes about the
phone call.

See a summary of the contacts
information.

See how much time you’ve
spent on the phone with
the contact.
Creating and Working with Contacts          35



SMS
dow will appear.

2. The Start Time, End Time, and Elapsed Time fields will automatically be filled in when the call is received 
and ended. If you opened a new Incoming Call window via the Attachments block, then you will need to 
manually enter the Start and End Times.

3. Click Start Billing to start the Billable Time. Click Pause Billing to pause the timer, and click Resume Billing 
to start the timer again.

4. Type a title for the incoming phone call and enter any applicable notes for the call.

5. The Start Time, End Time, and Billable Time can be edited by clicking in the field.

6. Click Save in the toolbar to save the note, or click Delete to delete the note.

The incoming call note will be saved and attached to the contact. You will be able to access the incoming call 
note from the Attachments block. For more information on the Attachments block see Working With Blocks in 
Chapter Creating and Working with Contacts on page 29.

SMS 
SMS (Short Message Service) is a service for sending and receiving text messages to and from cell phones that 
support SMS messages. SOHO Contacts can send an SMS message to a cell phone via iChat or a Bluetooth en-
abled cell phone. It can also receive SMS messages via a Bluetooth enabled cell phone.

To set up a Bluetooth enabled cell phone for sending and receiving SMS messages:

In order to use a cell phone for sending and receiving SMS messages, both your computer and cell phone will 
need to be Bluetooth enabled. Both devices will need to be paired using the Bluetooth pane of System Preferenc-
es.

1. Choose SOHO Contacts > Preferences, and click the Dialing button. All settings for Bluetooth SMS mes-
saging will be in the Bluetooth section of the Dialing preference pane.

2. Click the Choose button to select a Bluetooth enabled cell phone to use.

Send the contact an
SMS message.
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3. Click “Open Apple Bluetooth Preference Pane” if you need to pair a Bluetooth enable cell phone with your 
computer.

To enable a Bluetooth enabled cell phone for SMS messaging:

1. Choose SOHO Contacts > Use Bluetooth. If you want to enable Bluetooth automatically when you use 
SOHO Contacts, choose SOHO Contacts > Preferences, click the Dialing button and then enable “Start 
Bluetooth on application startup”.

To send an SMS message via a Bluetooth enabled cell phone or iChat:

1. Select a contact.

2. Click the action button next to a phone number. Be sure the phone number is for a cell phone capable of 
receiving an SMS message.

3. Choose “Send SMS Using Default Method” from the pop-up menu, or choose Send SMS and select Using 
Bluetooth or Using iChat. You can set the default SMS sender in the Dialing preferences.

4. Type the message you want to send. 

5. Click Send.

When you send an SMS message it will be saved into a new note, which will automatically be attached to the 
contact. You will be able to access the note from the Attachments block. For more information on the Attach-
ments block see Working With Blocks in Chapter Creating and Working with Contacts on page 29.

To receive an SMS message:

When you receive an SMS message via a Bluetooth enabled cell phone, SOHO Contacts will search for the con-
tact via the Caller ID number and open an Incoming SMS Message window. The Incoming SMS Message win-
dow will display the SMS message and you will be able to reply to it, call the contact, and show the contacts card. 
In order for this to work, you will need to have enabled Bluetooth (SOHO Contacts > Use Bluetooth).

The incoming SMS message will be saved into a new note, which will then be automatically linked to the contact. 
You will be able to access the note from the Attachments block. For more information on the Attachments block 
see Working With Blocks on page 29.

Attachments and Links
Not only can you attach notes, incoming/outgoing calls, incoming/outgoing SMS messages, files, tasks, events, 
etc. to a contact, but you can link contacts to each other to form relationships. Attachments appear in the At-
tachments block while contact links appear with action buttons in the contact card. For more information on 
the Attachments block see Attachments Block on page 30.

Task and Event Attachments

You can create and attach tasks and events to a contact. These attachments appear in the Attachments block and 
they also automatically appear in iCal.

Quickly send an SMS message.
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To create and attach a task/event to a contact:

1. Select a contact.

2. Click Add (+) in the Attachments block and choose Task or Event from the pop-up menu. A new task/event 
window will appear.

3. Fill-in the appropriate information.

4. Choose File > Save or close the window to save the task or event.

Note and File Attachments

You can attach notes and files to a contact. If you own SOHO Notes, you will be able to access and manage all 
attached notes and files from within SOHO Notes.

To attach a note to a contact:

1. Select a contact.

2. Click Add (+) in the Attachments block and choose Note from the pop-up menu. A note window will ap-
pear.

3. Enter a title for the note in the title field and any applicable notes.

4. Choose File > Save or click Save in the toolbar to save the note.

To link a file to a contact:

1. Select a contact.

2. Click Add (+) in the Attachments block and choose File from the pop-up menu.

3. Choose a file and select whether to copy it into the note or link it to the note.

• Copy into note: The file will be stored in the database.
• Link to note: A link to the file on disk will be stored in the database.

4. Click Open.

Contact Links

SOHO Contacts will automatically link contacts to each other when it can reliably determine a clear relation-
ship. For example, if you have a contact whose organization is Chronos, then the contact will automatically be 
linked to the Chronos organization if it exists. You can also manually link contacts to each other using the Re-
lationships block.

To link contacts manually in the Relationships block:

1. Select a contact that you wish to link to another contact.

2. Make sure the Relationships block is visible. For more information on blocks see see Working With Blocks 
on page 29.

3. Enter a contact name in a relationship field. As you type, SOHO Contacts will provide a list of contacts that 
you can choose from. Choose a contact from the list.

Open the linked contact
in a new tab.

Select the type of relationship
the two contacts have.
Creating and Working with Contacts          38



Print Labels, Envelopes, Letters, Fax Covers, Etc.
4. Click the label and choose the type of relationship the two contacts have from the pop-up menu.

5. Click the action button to open the linked contact in a new tab.

To have SOHO Contacts automatically link contacts:

SOHO Contacts will automatically create a link between a contact and its parent organization.

1. Create a new contact and mark it as an organization, i.e. ABC Company. For more information on marking 
a contact as an organization see Create a Contact on page 27.

2. Create another new contact and enter the above organization name into the organization field. As you type, 
SOHO Contacts will present a list of organizations that match what you’re typing.

3. Choose an organization. The organization will automatically be linked to the selected contact. Likewise, the 
selected contact will automatically be linked to the organization and will appear in the organization’s Rela-
tionships block using the selected contact’s job title. The organization’s address and URL will also automat-
ically be filled-in for the selected contact.

Print Labels, Envelopes, Letters, Fax Covers, Etc.
SOHO Contacts integrates with SOHO Print Essentials to print professional-looking labels, envelopes, letters, 
invoices, fax cover sheets, address books, etc.

To print business documents using SOHO Print Essentials:

1. Select one or more contacts. Hold down the shift key to select multiple contiguous contacts. Hold down the 
command key to select multiple contacts in a non-contiguous fashion.

2. Choose File > Print and then choose the document type you wish to print for the selected contacts. 

SOHO Print Essentials will automatically launch and present your chosen document type for your contact se-
lection.

Contact Views
SOHO Contacts has three views for viewing contact(s): Card and Columns view, Card view, and List view. This 
section will describe each view.

To switch views:

1. Choose View > Card and Columns, Card, or List. 

Card and Columns View

The Card and Columns view is the most popular view because it lets you organize your contacts in groups, quick-
ly make contact selections, browse contact information, and even edit contacts. The only difference is the Card 

Quickly switch between the different
contact views.
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view does not have the Group and Name columns.

Card View

The Card view is like the Card and Columns view without the columns. It is used to view or edit a single contact 
at a time especially when screen space is at a premium.
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List View

The List view allows you to view and edit multiple contacts at once.

To sort on a column:

1. Click on the column heading you wish to sort. A blue column heading indicates that the column is being 
sorted on. The arrow in the column heading will indicate whether the column is being sorted in ascending 
or descending order.

2. Hold down the Shift key and select another column to sort on. You can sort up to five different columns. 
The number in the column heading will indicate the order in which the column is being sorted. 

To edit text in a field:

1. Double-click inside the field you wish to edit.

2. Edit the field contents.

3. Press the return or tab key to save the change.

To change the group of contacts being displayed:

The List view shows the contacts in the group selected in the pop-up menu near the bottom of the view.

1. Select a group from the pop-up menu.

Sort on up to
five columns.

Edit any field in 
place.

Select which group of
contacts to display.

Quickly search for a
contact.
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Chapter 8

Miscellaneous

This chapter will describe how to import and export contacts, and backup your personal database.

Import/Export Contacts
SOHO Contacts can import and export contacts that are in the industry standard vCard format.

To import vCards:

1. Choose File > Import vCards.

2. Select the vCards you wish to import in the Open window.

3. Click Import to import the selected vCards. Or, you can drag and drop the vCard file(s) from the Finder to 
the Group or Name columns in SOHO Contacts.

To export contacts as vCards:

1. Select the contact(s) you wish to export in the Name column. Hold down the shift key to select multiple 
contiguous contacts. Hold down the command key to select multiple contacts in a non-contiguous fashion.

2. Choose File > Export vCards.

3. Select where you would like the vCard file to be saved.

4. Click Export. Or, you can select contact(s) in the Name column and drag them to the Finder to export them 
as vCards.

Back Up Your Personal Database
SOHO Contacts can make regular backups of your personal database. This is a safety feature in case you inad-
vertently delete some important information and need to restore a backup file.

WARNING: Depending upon which of Chronos’ integrated suite of products you own, your database may con-
tain notes, contacts, and calendars. When you back up a database, all notes, contacts, and calendars in the data-
base are backed up. Likewise, if you later restoring a database backup, it will completely replace the notes, 
contacts, and calendars on your computer with those in the backup.

To set up automatic backups:

1. Choose SOHO Contacts > Preferences, and click the Backups button. 

2. Set the various backup options:

• Automatically perform backups. This option lets you choose how often SOHO Contacts should make 
a backup. By default, backups will be created on a daily basis.

• Maximum number of backups to keep. Enter the maximum number of backups to keep. When a new 
backup file is created, the oldest backup file will be deleted so that the maximum number of backup files 
won’t be exceeded. To permanently save a particular backup file, you must move it outside of the back-
up folder or it will eventually be deleted.

• Location for backups. By default, backup files are saved in the directory: ~/Library/Application Sup-
port/SOHO Contacts/Backups, where “~” denotes your home folder. Click Choose Backup Location 
to select a different backup folder. 
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Back Up To Your Hard Disk

To manually back up your personal database to your hard disk:

1. Choose File > Back Up Database > To a File.

2. Name the backup file and choose where it should be saved to.

3. Click Save to save the backup file.

To undo all recent changes and return to a database backup on your hard disk:

1. Choose File > Restore Database > From a File.

2. Select a backup file from the Open dialog.

3. Click Open to restore the database backup. Any new notes, contacts, calendars, etc. that you've changed 
since the backup was created will be lost. Any deleted items will be recovered.

Back Up To .Mac

If you have a .Mac account with Apple, SOHO Contacts can make a backup of your personal database to your 
iDisk, and then later restore the database backup. In addition, you can use the .Mac backup feature to move your 
personal database between multiple computers although using .Mac synchronization is the easier and safer way 
to accomplish this. In order to use the .Mac backup feature, you will need a .Mac account from Apple. For more 
information on obtaining a .Mac account see http://www.chronosnet.com/dotmacaccount.html.

To manually back up your personal database to your .Mac account:

1. Choose File > Back Up Database > To .Mac.

2. Follow the prompts and your database will be backed up. The backup will be created in the following direc-
tory on your iDisk: /Documents/Chronos/

To undo all recent changes and return to a database backup on .Mac:

1. Choose File > Restore Database > From .Mac. Any new notes, contacts, calendars, etc. that you've changed 
since the backup was created will be lost. Any deleted items will be recovered.

To move a database between multiple computers:

You can use the .Mac backup feature to move your personal database between multiple computers. Please note 
that moving your personal database between computers is different than synchronizing your data between com-
puters. The following example will show you how to move your database between a home computer and a work 
computer.

Before you leave to work, sit down at your home computer and do the following:

1. Launch SOHO Contacts.

2. Choose File > Back Up Database > To .Mac.

Once you arrive at work, do the following on your work computer:

1. Launch SOHO Contacts.

2. Choose File > Restore Database > From .Mac. This will replace the database on your work computer with 
the database from your home computer. Please note that restoring a backup does not synchronize your 
notes. Rather, it overwrites your notes with those in the backup.

When you’re ready to move the database back to your home computer, do the previous steps again but this time 
you’ll be starting out on your work computer instead of your home computer.
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Synchronization Helper Applications
Chapter 9

Universal Synchronization

The personal database on your computer may contain notes, contacts, and calendars that were created by SOHO 
Notes, SOHO Contacts, or SOHO Calendars depending upon which SOHO series products you own. The in-
formation in your personal database can be synchronized to other applications (Apple’s Address Book, Apple’s 
iCal, etc.) and/or devices (cell phones, P.D.A.’s, etc.) attached to your computer. This means, for example, that 
your contacts in SOHO Contacts will automatically synchronize and appear in Apple’s Address Book application 
and on your cell phone. Your information will thus become universally available on your computer and devices. 
This universal synchronization uses and requires the synchronization technology built-in to Mac OS X 10.4 and 
later.

Any application, device, or computer that supports synchronization technology built-in to Mac OS X 10.4 will 
be able to synchronize with the notes, contacts, and calendars in your personal database. If you have an Apple 
.Mac account (must be purchased separately), you can even synchronization your notes, contacts, and calendars 
between multiple computers.

This chapter will describe how synchronization works, explain what happens during your first synchronization, 
detail how to synchronize your data between multiple computers, and cover how to synchronize your informa-
tion with cell phone and P.D.A. devices.

Synchronization Helper Applications
The SOHO Series products use two background helper applications called SOHO Sync and ChronosCalen-
darsService to synchronize the information in your personal database. Each of these applications are automati-
cally launched whenever its services are needed and automatically quits when it’s finished. This means you do 
not need to worry about manually running either. We mention these applications in case you see them running 
and wonder what they are.

■ SOHO Sync. This application works in conjunction with Sync Services (part of Mac OS X) to keep your 
notes, contacts, and calendars synchronized.

■ ChronosCalendarsService. This application helps ensure shared databases remain synchronized with iCal.

Your First Synchronization
The first time SOHO Sync runs, three Sync Alert windows will appear: one for notes, one for contacts, and one 
for calendars. This section will describe the choices these alerts present so you can respond accordingly.
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Your First Synchronization
Sync Alert for Notes

To respond to the Sync Alert window for Notes:
■ Delete all notes from SOHO Sync before syncing. This option will only take affect if you click the Allow 

button. If you enable this option, all the notes in your personal database will be deleted prior to synchroniz-
ing notes from Apple’s .Mac. If you don’t enable this option, the notes in your personal database will be 
merged with notes on Apple’s .Mac.

■ Allow. If you click Allow, your notes will be synchronized based on what you chose for the “Delete all notes 
from SOHO Sync before syncing” option. The Allow option is the preferable choice.

■ Don’t Allow. If you click Don’t Allow, then notes in your personal database will not be synchronized at this 
time and this alert will reappear during the next synchronization session.

Sync Alert for Contacts

To respond to the Sync Alert window for Contacts:
■ Delete all contacts from SOHO Sync before syncing. This option will only take affect if you click the Allow 

button. If you enable this option, all the contacts in your personal database will be deleted prior to synchro-
nizing contacts from other applications such as the Apple’s Address Book. If you don’t enable this option, 
the contacts in your personal database will be merged with contacts in other applications and devices on your 
computer.

■ Allow. If you click Allow, your contacts will be synchronized based on what you choose for the “Delete all 
contacts from SOHO Sync before syncing” option. The Allow option is the preferable choice.

■ Don’t Allow. If you click Don’t Allow, then contacts in your personal database will not be synchronized at 
this time and this alert will reappear during the next synchronization session.
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.Mac Synchronization
Sync Alert for Calendars

To respond to the Sync Alert window for Calendars:
■ Delete all calendars from SOHO Sync before syncing. This option will only take affect if you click the Al-

low button. If you enable this option, all the calendars in your personal database will be deleted prior to syn-
chronizing calendars from other applications such as the Apple’s iCal. If you don’t enable this option, the 
calendars in your personal database will be merged with calendars in other applications and devices on your 
computer.

■ Allow. If you click Allow, your calendars will be synchronized based on what you choose for the “Delete all 
contacts from SOHO Sync before syncing” option. The Allow option is the preferable choice.

■ Don’t Allow. If you click Don’t Allow, then calendars in your personal database will not be synchronized 
at this time and this alert will reappear during the next synchronization session.

.Mac Synchronization
The synchronization technology in Mac OS 10.4 and later will even let you synchronize your notes, calendars, 
and contacts between multiple computers using an Apple .Mac account (must be purchased separately). In order 
to use the .Mac sync feature, you will need a .Mac account from Apple. For more information on obtaining a 
.Mac account see http://www.chronosnet.com/dotmacaccount.html.

To set up a SOHO series product to synchronize with .Mac:

1. Open the System Preferences and click the .Mac button.

2. Click the Sync tab.

3. Choose how often you want your information synchronized to your .Mac account. You may want to base 
your choice on the speed of your Internet connection and how often you need your information kept up to 
date. There are even options to only synchronize when you manually tell it to or automatically whenever the 
system determines it needs to.

4. Enable Notes, Contacts, and Calendars in the list depending on what information you want synchronized 
with .Mac. This means you can synchronize contacts to your .Mac account, but not notes and calendars.

To reset the data in your personal database with .Mac data or vice versa:

If you want to replace the data in your database with the data in your .Mac account, or vice versa, follow the 
below steps:

1. Open the System Preferences and click the .Mac button.

2. Click the Advanced tab.

3. Click Reset Sync Data.

4. Choose the data you want to reset.

5. Choose whether you want to replace the data on your computer with sync info from .Mac or vice versa.

6. Click Replace.
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P.D.A. and Phone Synchronization
P.D.A. and Phone Synchronization
The calendar and contact information in your personal database can not only be synchronized with other appli-
cations like Apple’s Address Book or iCal, but can also be synchronized with your cell phone or P.D.A. using 
Apple’s iSync. For more information on which devices iSync supports and how to use iSync, please visit http://
www.apple.com.

iPod Synchronization
The calendar and contact information in your personal database can be synchronized to your iPod using Apple’s 
iTunes. For more information on synchronizing calendar and contact information to an iPod, please visit http:/
/www.apple.com.
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