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Chapter 1

 

Welcome to SOHO Calendars

 

SOHO Calendars is the easiest way to share calendars on Mac OS X. It integrates seamlessly with Apple’s iCal 
which means shared calendars show up automatically in iCal. Changes made to a shared calendar in iCal auto-
matically show up on everyone else’s shared calendar in iCal which means workgroup members can continue to 
use software familiar to them. Plus, SOHO Calendars is part of the integrated SOHO series of products which 
means if you own other SOHO series products like SOHO Contacts, you can link your contacts and calendars 
together for a total solution. For a list of new features in version 5 please visit our web site at http://www.chro-
nosnet.com.

 

System Requirements

 

■

 

Apple Macintosh G3 or higher

 

■

 

Mac OS X v10.4.3 or later

 

■

 

55MB of available disk space

 

Learning to Use SOHO Calendars

 

To learn how to use SOHO Calendars, consult these resources:

 

User’s Guide

 

This guide describes the SOHO Calendars’s features and shows how to use the program.

 

Technical Support

 

Chronos provides various support options for SOHO Calendars. See http://www.chronosnet.com/Support/in-
dex.html for technical support options.

 

Web Resources

 

Go to http://www.chronosnet.com/Products/index.html to get the latest software and updates for SOHO Cal-
endars.

 

Upgrade Information

 

Please visit http://www.chronosnet.com/Support/ to get the latest information on upgrading from Personal or 
Group Organizer to SOHO Calendars.



 
A Single Database For Notes, Contacts, & Calendars

                                  
Chapter 2

SOHO Integration

SOHO Notes, SOHO Contacts, and SOHO Calendars are all part of an integrated software series designed to 
help you focus on your business. While each product stands on its own and can be used independently of the 
others, they’re crafted to work seamlessly together for unprecedented power and convenience. The purpose of 
this chapter is to introduce important concepts related to the integrated nature of these products.

A Single Database For Notes, Contacts, & Calendars
The SOHO series of products store their notes, contacts, and calendars in a single database. An integrated data-
base offers several benefits:

■ Seamless Linking. Notes, contacts, and calendars can seamlessly be linked to each other without complica-
tions.

■ Persistent Relationships. Since notes, contacts, and calendars all exist in the same database, relationships 
between these objects cannot be broken accidentally or easily. When these object are in separate databases, 
you must be careful to always keep the separate databases together since their contents are tightly related.

■ Portability. Moving a database from one computer to another is easy since notes, contacts, calendars and 
their relationships are all stored in a single database file.

■ Simple Backups. Backing up all your important information is easier because you only have one database 
to manage.

■ Easy Administration. If you’re operating in a multi-user environment, there’s only one database to admin-
ister for notes, contacts, and calendars. This means a single list of user accounts to manage instead of three 
separate lists to keep synchronized. Plus, you can manage note, contact, and calendar access privileges from 
any SOHO Series product.

Single & Multi-User Enabled
SOHO Notes, SOHO Contacts, and SOHO Calendars are designed for both single and multi-user use out of 
the box without any additional software to purchase. This means the software is as equally suited for a user work-
ing individually at home as it is for a workgroup of twenty on an office network. The built-in dual use nature of 
these integrated products offers several benefits:

■ Simple Purchase Decision. There aren’t any complicated decisions to make since it’s the same product for 
a single or multi-user environment. Simply purchase a single-user license for individual use or a volume li-
cense for multi-user use. Suppose, for example, your company has twenty users who wish to use SOHO 
Notes—simply purchase a 20-user pack.

■ Easy, Cost-Efficient Expansion. You can start out using the SOHO series products for individual use and 
expand to multi-user use at any time without complicated conversions, etc. Simply purchase a volume li-
cense once you’re ready. Licenses are additive so if you start out with a single user license and later buy a 5-
user pack, you’ll have licensing for a workgroup of six users.

■ Same Easy-To-Use Interface. Since the same software is used for both single and multi-user use, you’ll use 
the same easy-to-use interface for both. This means expanding from a single-user environment to a multi-
user environment the experience will be the same and familiar.

■ Flexible Configurations. You can mix and match licensing between SOHO series products to meet your 
needs. For example, you can have five SOHO Notes users and thirty SOHO Calendars users accessing the 
same shared database. Further, the five SOHO Notes users don’t necessarily have to be part of the group of 
thirty SOHO Calendars users. Such flexibility lets you decide the needs of your business and purchase ac-
cordingly instead of forcing you to purchase products you don’t need. Of course, the best idea is to purchase 
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the complete SOHO series for all your users so they all have access to best tools!
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Chapter 3

Installation

This chapter will discuss the steps required to install SOHO Calendars in either a single or multi-user environ-
ment. The single user installation is intended for users who will be installing the product for personal use. The 
multi-user installation is intended for workgroups that wish to share information with multiple users over a net-
work while still providing personal use for each user. This chapter will also discuss what gets installed and how 
to uninstall the product.

Installation (Single User)
The single user installation is intended for those users who wish to install the product for personal use.

To install SOHO Calendars for a single user from a disc:

1. Insert the SOHO Calendars disc into your computer’s optical drive and double-click the installer icon.

To install SOHO Calendars for a single user from a download:

1. Open the SOHO Calendars disk image on your desktop and double-click the installer icon.

For a list of items that get installed on the hard disk see What Gets Installed? on page 7.

Installation (Multi-User)
The multi-user installation is intended for workgroups who wish to share information with multiple users over 
a network while still providing personal use for each user.The multi-user installation involves installing SOHO 
Calendars on both a server computer and each client computer. The same installer is used for both the server and 
client computers.

Note: the server should be a computer on the network that is accessible by all the users who will be accessing it. 
The server computer can be any computer whether it’s a dedicate server or the administrator’s personal machine. 
It’s also a good idea to choose a server whose network address is static and won’t be changing.

To install SOHO Calendars on a server and each client machine from a disc:

1. Insert the SOHO Calendars disc into your computer’s optical drive and double-click the installer. Repeat 
this step on the server computer and each client computer.

To install SOHO Calendars on a server and each client machine from a download:

1. Open the SOHO Calendars disk image and double-click the installer. Repeat this step on the server com-
puter and each client computer.

Once you have installed SOHO Calendars on the server and client machines, you will need to set up SOHO 
Calendars for network access, see Get Started (Multi-user Environment) in Chapter Get Started (Multi-user Envi-
ronment) on page 11 for more information. For a list of items that get installed on the hard disk see What Gets 
Installed? on page 7.

What Gets Installed?
The SOHO Calendars installer will install the following items on to your hard disk (“~” denotes your home fold-
er).

■ SOHO Calendars. This is the main application. The SOHO Calendars application will be installed into a 
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folder named “SOHO Series” which will be installed in your main Applications folder: /Applications/
SOHO Series

■ Chronos/SOHO Calendars. This folder stores pictures, textures, and other related files and is installed into 
the “Application Support” folder of your home Library folder: ~/Library/Application Support/Chronos/
SOHO Calendars/

■ SOHO Sync. This is a helper application for SOHO Calendars. The SOHO Sync application is installed 
into the “Helper Applications” folder of the “Chronos” folder: ~/Library/Application Support/Chronos/
Helper Applications/

■ ChronosCalendarsService. This is a helper application for SOHO Calendars. The ChronosCalendarsSer-
vice application is installed into the “Helper Applications” folder of the “Chronos” folder: ~/Library/Appli-
cation Support/Chronos/Helper Applications/

■ ChronosNotesCM.plugin. This is the SOHO Notes contextual menu plugin file and it is installed into the 
“Contextual Menu Items” folder of the “Application Support” folder of your home Library folder: ~/Li-
brary/Contextual Menu Items/ChronosNotesCM.plugin

■ ChronosNotesService. This is a helper application for SOHO Notes. The ChronosNotesService application 
is installed into the “Services” folder of your home Library folder: ~/Library/Services/ChronosNotesService

■ ChronosNotesConduit. This is the conduit that synchronizes notes between SOHO Notes and a Palm 
handheld. The ChronosNotesConduit is installed in the Conduits folder: /Library/Application Support/
Palm HotSync/Conduits 

■ ChronosNotes.wdgt. This is the SOHO Notes widget. The widget is installed into the “Widgets” folder of 
your home Library folder: ~/Library/Widgets/ChronosNotes.wdgt

■ OpenBase. This is the database engine SOHO Calendars uses to store your information. The installer places 
files in several locations:
• /Library/OpenBase
• /Library/StartupItems/OpenBase
• /Library/Frameworks/OpenBase…framework
• /Library/Java/Extensions/OpenBaseJDBC.jar
• /Applications/OpenBase

Uninstall
SOHO Calendars and its related files can be uninstalled two different ways: manually or via the installer.

To uninstall SOHO Calendars via the installer:

1. Double-click the installer.

2. Choose Uninstall from the “Easy Install” pop-up menu.

3. Follow the on-screen prompts.

To uninstall SOHO Calendars manually:

The below steps describe how to uninstall of the components related to SOHO Calendars except for the Open-
Base components. Caution must be taken when uninstalling the software since StickyBrain, SOHO Notes, 
SOHO Contacts, and SOHO Calendars share certain installed components as noted. Note: the OpenBase com-
ponents can only be uninstalled using the uninstall option in the SOHO Calendars installer.

1. Delete the “SOHO Calendars” application from the “SOHO Series” folder. This is located in the “Appli-
cations” folder. If you are not using any other SOHO products from Chronos, delete the “SOHO Series” 
folder.

2. Delete the “Chronos/SOHO Calendars” folder. This is located in the “Application Support” folder of your 
home Library folder.

3. Delete the “ChronosNotesCM.plugin” from the Contextual Menu Items folder of your home Library fold-
er. Do not delete this file if you’ll still be using StickyBrain or SOHO Notes.
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4. Delete the “ChronosNotes.wdgt” from the Widgets folder of your home Library folder. Do not delete this 
file if you’ll still be using StickyBrain or SOHO Notes.

5. Delete the “ChronosNotesService” from the Services folder of your home Library folder. Do not delete this 
file if you’ll still be using StickyBrain or SOHO Notes.

6. Delete the “ChronosNotesConduit” file. This is located in the directory: /Library/Application Support/
Palm HotSync/Conduits/. Do not delete this file if you’ll still be using StickyBrain or SOHO Notes.

7. Delete the “SOHO Sync” from the “Helper Applications” folder of the “Chronos” folder: ~/Library/Appli-
cation Support/Chronos/Helper Applications/. Do not delete this file if you’ll still be using SOHO Notes, 
SOHO Contacts, or SOHO Calendars.

8. Delete the “ChronosCalendarsService” from the “Helper Applications” folder of the “Chronos” folder: ~/
Library/Application Support/Chronos/Helper Applications/. Do not delete this file if you’ll still be using 
SOHO Notes, SOHO Contacts, or SOHO Calendars.

9. Delete the “com.chronos.SOHONotes.plist” file. This file is located in the “Preferences” folder of your 
home Library folder.

10. Delete the “com.chronos.ChronosNotesService.plist” file. This file is located in the “Preferences” folder of 
your home Library folder.

11. Delete the “ChronosNotesService.bundle” file. This file is located in the “Services” folder of your home Li-
brary folder.
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Get Started (Single-user Environment)

The purpose of this chapter is to show you how to get started with SOHO Notes, SOHO Contacts, or SOHO 
Calendars in a single-user environment depending upon which product(s) you own.

Personal Database
Each user always has a “personal” database on his/her machine in which his/her personal notes, contacts, and 
calendars are stored. The personal database is automatically created the first time SOHO Notes, SOHO Con-
tacts, or SOHO Calendars is launched. This database is called “Chronos_username.db” and is always stored on 
the user’s local hard disk. Information in a personal database cannot be shared with others.

Get Started
To start working with notes:

1. Launch SOHO Notes. A collection of default folders in your personal database will appear in the folders 
region. You can add notes to these folders or create your own folders.

To start working with contacts 

1. Launch SOHO Contacts. SOHO Contacts will automatically synchronize with the Mac OS X Address 
Book and your contacts from the Address Book will start appearing in SOHO Contacts. This may take any-
where from a few seconds to a few minutes depending upon how many contacts you have. 

To start working with calendars:

1. Launch SOHO Calendars. SOHO Calendars will automatically synchronize with Apple’s iCal and your cal-
endar information from iCal will start appearing in SOHO Calendars. This may take anywhere from a few 
seconds to a few minutes depending upon how much calendar information you have. For more traditional 
calendar views, you will use Apple’s iCal to view and edit the calendar information stored in your personal 
database.

To print business documents:

1. Launch SOHO Print Essentials.

2. OR Launch SOHO Contacts and choose Print > Labels, Envelopes, Fax Covers, etc. to print the documents 
of your choice for the currently selected contacts.
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Get Started (Multi-user Environment)

The purpose of this chapter is to show you how to set up SOHO Notes, SOHO Calendars, or SOHO Contacts 
in a multi-user environment. This chapter is intended for both administrators and end users. It’s important to 
remember that each of these applications can store their information in the same database. In other words, a da-
tabase can contain notes, calendars, and contacts. This allows for seamless integration between these products 
and a great user experience for your workgroup. For example, notes linked to a contact will appear in both 
SOHO Notes and SOHO Contacts. Although these applications are integrated, they can still be used on their 
own independent of one another. 

The setup for each of these applications in a network environment is the same. This chapter will therefore de-
scribe the setup process for all three products. Plus, there’s a good chance that if you’re setting up one SOHO 
series product, you might be setting up the others as well.

SOHO Notes, SOHO Calendars, and SOHO Contacts are multi-user applications which means a few things:

■ Note, calendar, and contact information can be stored for more than one user in a single database.
■ Multiple users can access the same database simultaneously.
■ Multiple databases can be created on a shared computer.
■ Access privileges can be applied to restrict access to notes, calendars, and contacts on a per user basis.

Personal Database Versus Shared Databases
Each user always has a “personal” database on his/her machine in which his/her personal notes, contacts, and 
calendars are stored. The personal database is automatically created the first time SOHO Notes, SOHO Con-
tacts, or SOHO Calendars is launched. This database is called “Chronos_username.db” and is always stored on 
the user’s local hard disk. Information in a personal database cannot be shared with others.

A “shared” database, on the other hand, is created by an administrator on a shared server. The server should be 
a computer on the network that is accessible by all the users who will be accessing it. The server computer can 
be any computer whether it’s a dedicate server or the administrator’s personal machine. It’s also a good idea to 
choose a server whose network address is static and won’t be changing.

Set up Your Server (Administrators)
This section will discuss the steps, you the administrator, will need to perform to set up network access for a 
SOHO series product. This section assumes you have already installed the SOHO software on the server and 
each of the clients. We highly suggest you read the entire section before getting started. This will help you to 
understand the setup process a little better.

Develop a Game Plan

Setting up SOHO Calendars in multi-user environment is straightforward and simple. A little pre-thinking and 
planning will, however, will make the task even easier and less time-consuming. Below are some questions that 
will help you gain insight into the needs of your organization. Your answers will form the basis of your game plan 
and will be used in future installation and setup steps.

■ List all the people including yourself who will be using SOHO Calendars. You will be creating a user account 
for each of these individuals.

■ Which computer will be used as the designated server?
■ If you’re setting up SOHO Notes, make a list of folders you will want users to store shared notes in. For 
Get Started (Multi-user Environment)          11



Set up Your Server (Administrators)
example, you might create a folder for each department in your organization with sub-folders for projects 
each department is working on.
• Next to each folder, list each user who will need access to it. For example, you might want John, Susan, 

and Jennifer to have access to the Marketing Department folder.
• Next to each user name, indicate whether you want the user to have read, write, or read & write access 

to the notes in the folder. For example, you might give John read-only access to the folder while Susan 
and Jennifer have full read/write access.

■ If you’re setting up SOHO Contacts, write down which users you want to have read and read/write access 
to the contacts in the database.

■ If you’re setting up SOHO Calendars, make a list of calendars you will want users to store events and to-dos 
in. For example, you might create calendars for each department in your organization.
• Next to each calendar, list each user who will need access to it. For example, you might want only John 

and Jennifer to have access to the Marketing Department calendar.
• Next to each user name, indicate whether you want the user to have read, write, or read & write access 

to the calendar. For example, you might give John read-only access to the folder while Jennifer has full 
read/write access.

The following is an example game plan:

User Accounts: Sam, Jennifer, Mark, John

Server Computer: G5 Server (192.168.0.1)

Note Folders: Marketing (John—read, Susan—read/write, Jennifer—read/write); Human Resources 
(Sam—read/write, Mark—read/write)

Contact Privileges: Sam—read, Jennifer—read/write, Mark—none, John—read

Calendar Privileges: Marketing (John—read, Jennifer—read/write); Human Resources (Sam—read/write, 
Mark—read/write)

Configure Server Software

The SOHO series products use a commercial database system called OpenBase to store information in. Open-
Base is automatically installed on both the client and server computers as part of the installation process. In order 
for users to access a shared database on a server, you will need to configure OpenBase on the server to allow net-
work access. You don’t need to do this on the client computers since they won’t be accepting external access. If 
you have firewall software running on the server computer, you will need to open up certain ports for OpenBase.

To configure OpenBase for network access:

You configure OpenBase using the OpenBase Manager application which is automatically installed for you.

1. Move to your server computer.

2. Launch the OpenBase Manager application located at /Applications/OpenBase/

3. Choose OpenBaseManager > Local Host Settings.

4. Enable Network Access Allowed. This will allow client machines to connect to shared databases on the server 
computer.

5. OPTIONAL. Click the Read Password Not Secure button to set a read password. If a Read password is set, 
only authorized users may connect to shared databases on the server computer. 

6. OPTIONAL. Click the Host Password Not Secure button to set a host password. If a Host password is set, 
only authorized users may create and delete shared databases on the server computer.

If you need to remove the Read or Host password, click the Read Password Secured or Host Password Secured 
button and leave Password and Verify fields blank and click the Continue button.
Get Started (Multi-user Environment)          12



Set up Shared Databases (Administrators)
To open TCP ports in the firewall on the server computer:

If you have firewall software running on the server computer, you will need to open up certain TCP ports in the 
firewall to allow client computers to access the shared database on the server computer. This only needs to be 
done on the server, not the client computer. Open the following TCP ports in your firewall software on the serv-
er:

■ 20221 and 20222. OpenBase uses these TCP ports for getting the information needed to connect to Open-
Base databases by name. 

■ 20223 through 20300. OpenBase uses this range of TCP ports for database ports. Each database will run 
on its own port.

Please consult the help resources of your firewall software for information on opening and closing TCP ports.

Set up Shared Databases (Administrators)
This section will describe how to create and configure shared databases. It assumes you have a game plan in place 
as discussed in the previous section.

Database Manager

The Database Manager is where you will create and delete shared databases, set up user accounts, and assign ac-
cess privileges. The following sections will discuss each of these tasks in detail. This section will show you how 
to access the Database Manager for administrators.

To access the Database Manager for administrators:

1. Launch SOHO Calendars.

2. Choose File > Manage Databases. The Database Manager window will appear.

3. Click the Administrator button to see the administrator options.

Create/Delete Shared Databases

This section will show you how to create and delete shared databases on the server. You do not need to be at the 
server computer in order to do this. You can do this from any client computer.

To create a shared database:

1. Choose File > Manage Databases and click Administrator.

2. Select New Database from the Database pop-up menu. The New Database window will appear.
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Set up Shared Databases (Administrators)
3. Enter the server address of the computer that you want the database to be created on. The server address can 
be in the form of 192.168.0.1, http://www.chronosnet.com, or some-name-power-mac-g5.local. Use the 
server name “localhost” or “127.0.0.1” if you want to create the database on the computer you’re sitting at.

4. Enter a database name of your choosing.

5. Enter the name for the admin account. The admin account will be the account that is used to administer 
the database. Since you’re the admin, you can use your own name or other name of your choosing. There 
can only be one admin account.

6. Enter a password for the admin account. You MUST remember this password. If you forget this password, 
you will not be able to reset it. A fee-based password recovery service is the only way to recover your password 
if you lose it. Visit http://www.chronosnet.com/Support/ for more information.

7. Re-confirm the password you typed in the previous step.

8.  Click Create to create the database.

The database will be created on the server computer you specified. The database will be listed in the Database 
pop-up menu so you can add user accounts and assign access privileges.

To delete a database:

1. Choose File > Manage Databases and click Administrator.

2. Select the database you wish to delete from the Database pop-up menu. If the database is not listed in the 
pop-up menu, then select Open Database from the pop-up menu and open the database. Be sure to log in 
using your administrator name and password.

3. Select Delete Selected Database from the Database pop-up menu. You’ll be asked to confirm the delete since 
deleting a deleting a database is a permanent operation and cannot be undone.

Set up User Accounts

A user account will need to be set up for each individual that is going to access a shared database. A user account 
consists of a user name and password.

To add a user account:

1. Choose File > Manage Databases and click Administrator.

2. Select a database from the Database pop-up menu. If the database is not listed in the pop-up menu, then 
select Open Database from the pop-up menu and open the database. Be sure to log in using your adminis-
trator name and password.

Add/Remove user accounts.

Quickly see a list of user
accounts in a database.

Administer multiple databases
within the Database Manager
window.
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3. Click Add (+). A new user account will be created in the selected database.

4. Type in a user name and password for the user account. Each individual user will be able to change their 
password later, so you may want to use a temporary password when you first create a user account.

Repeat these steps for each user account you need to create.

To edit a user account:

If a user forgets his/her user name or password, you can reset it for them by editing their user account.

1. Choose File > Manage Databases and click Administrator.

2. Select a database from the Database pop-up menu. If the database is not listed in the pop-up menu, then 
select Open Database from the pop-up menu and open the database. Be sure to log in using your adminis-
trator name and password.

3. Double-click the user name or password you wish to edit in the user list.

4. Type in a new user name or password.

To delete a user account:

1. Choose File > Manage Databases and click Administrator.

2. Select a database from the Database pop-up menu. If the database is not listed in the pop-up menu, then 
select Open Database from the pop-up menu and open the database. Be sure to log in using your adminis-
trator name and password.

3. Select the user account in the user list.

4. Click Minus (-).

Assign Access Privileges

Access privileges provide a way to control the information in a database a user has access to. Access can be indi-
vidually controlled for notes, contacts, and calendars. For example, notes are organized by folders, so access priv-
ileges are assigned on a per folder basis for each user account. This gives you flexibility in controlling which 
information users have access to. There are three levels of access that can be granted to a user:

• None. The user does not have any access to the item.
• Read. The user can view the contents of an item, but cannot change it.
• Write. The user can add or modify the contents of an item. It is possible to assign write-only access in 

certain situations. For example, you can give a user write-only access to the Trash folder for notes. This 
means the user can place a note in the Trash, but can’t see the contents of the trash. In this case, you 
can think of a write-only folder as a “drop” folder.

Each item can be assigned a combination of these access privileges. For example, you can give John Read and 
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Write access to a calendar, but only give Susan Read access to the same calendar.

To assign access privileges for notes:

Access privileges for notes are assigned on a per folder basis. There are two default folders in a database: Unfiled 
and Trash. The next section will show you how to create a folder in a shared database.

1. Choose File > Manage Databases and click Administrator.

2. Select a database from the Database pop-up menu. If the database is not listed in the pop-up menu, then 
select Open Database from the pop-up menu and open the database. Be sure to log in using your adminis-
trator name and password.

3. Select a user account from the user list.

4. Select Notes from the Show pop-up menu.

5. Assign access privilege(s) for each folder listed. 

Repeat these steps for each user account.

To create folders in a shared database:

Only the administrator can create a folder in a shared database. You will need to have SOHO Notes running 
and the shared database open in order to create folders in it.

1. Select a shared database in the folder list. The shared databases will be located at the top of the folder list.

2. Choose Folder > New.

3. Type a name for the folder and click OK.

Repeat these steps for each folder you want to create in a shared database.

To assign access privileges to calendars:

Access privileges for calendars are assigned on a per calendar basis. The next section will show you how to create 
a calendar in a shared database.

1. Choose File > Manage Databases and click Administrator.

2. Select a database from the Database pop-up menu. If the database is not listed in the pop-up menu, then 
select Open Database from the pop-up menu and open the database. Be sure to log in using your adminis-
trator name and password.

3. Select a user account from the user list.

4. Select Calendars from the Show pop-up menu.

Assign access privileges to
each item.

Quickly mark all items with
an access privilege.
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5. Select a user account.

6. Assign access privilege(s) for each calendar listed.

Repeat these steps for each user account.

To create calendars in a shared database:

Only the administrator can create a calendar in a shared database.

1. Choose File > Manage Databases and click Administrator.

2. Select a database from the Database pop-up menu. If the database is not listed in the pop-up menu, then 
select Open Database from the pop-up menu and open the database. Be sure to log in using your adminis-
trator name and password.

3. Select Calendars from the Show pop-up menu.

4. Click Add (+) at the bottom of the calendar list.

5. Type a name for the new calendar.

Repeat these steps for each calendar you want to create in a shared database.

To assign access privileges to contacts:

Access privileges for contacts are assigned on an all or nothing basis in a shared database.

1. Choose File > Manage Databases and click Administrator.

2. Select a database from the Database pop-up menu. If the database is not listed in the pop-up menu, then 
select Open Database from the pop-up menu and open the database. Be sure to log in using your adminis-
trator name and password.

3. Select a user account from the user list.

4. Select Contacts from the Show pop-up menu.

5. Assign access privilege(s) for All Contacts.

Repeat these steps for each user account.

Distribute Information to End Users

The end users in your organization will need to know the following information in order to connect to a shared 
database:

■ Account name and password.
■ Name of shared database.
■ Server address.
■ Read password (if one was set).

An example:

User Name: Susan

Password: 1234

Database: CompanyDB

Server Address: 192.168.0.1 or http://www.chronosnet.com

Read Password: 5678
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Shared Database Backups (Administrators)
The administrator of a shared database will need to manually make a backup of it. In order to backup or restore 
a shared database, you need to be at the computer that the shared database is hosted on. Furthermore, you need 
to make sure ALL users are logged off of the shared database before proceeding

To backup a shared database:

1. Launch the OpenBase Manager application: /Applications/OpenBase/

2. Click the Local button and select the shared database in the list.

3. Choose Action > Configure Database.

4. Click the Backup tab.

5. Enable “Create a compressed copy of the database”.

6. Set the Backup Directory and Schedule. We suggest setting the schedule to a time when users will not be 
accessing the shared database.

To undo all recent changes and return to a database backup:

1. Uncompress the backup database by double-clicking it. You’ll end up with a native OpenBase database file.

2. Launch the OpenBase Manager application: /Applications/OpenBase/

3. Click the Local button and select the shared database in the list that you want to restore.

4. Choose Action > Stop Database, and then Action > Delete Database to delete your existing shared database. 
Use caution when performing this step since it will delete the current database so it can be replaced with the 
backup.

5. Drag the native OpenBase database file that was uncompressed to the following directory: /Library/Open-
Base/Databases/

6. In OpenBase Manager select the database in the list. It may take a few minutes before the database shows 
up in the list.

7. Choose Action > Start Database.

Get Started (End Users)
This section will describe how to get started depending upon which SOHO series products you own.

To start working with notes:

1. Launch SOHO Notes. A collection of default folders in your personal database will appear in the folders 
region. You can add notes to these folders or create your own folders.

2. Follow the steps in the next section to connect to one or more shared databases that your administrator cre-
ated.

To start working with contacts 

1. Launch SOHO Contacts. SOHO Contacts will automatically synchronize with the Mac OS X Address 
Book and your contacts from the Address Book will start appearing in SOHO Contacts. This may take any-
where from a few seconds to a few minutes depending upon how many contacts you have.

2. Follow the steps in the next section to connect to one or more shared databases that your administrator cre-
ated.

To start working with calendars:

1. Follow the steps in the next section to connect to one or more shared databases that your administrator cre-
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ated.

2. Launch Apple’s iCal. Both your personal calendars and calendars in shared databases will appear in iCal. You 
can use iCal to view and edit both personal and shared calendar information. You can also attach events/
tasks to contacts in SOHO Contacts and these events/tasks will automatically appear in iCal.

To print business documents:

1. Launch SOHO Print Essentials.

2. OR launch SOHO Contacts and choose Print > Labels, Envelopes, Fax Covers, etc. to print the documents 
of your choice for the currently selected contacts.

Connect to a Shared Database (End Users)
When you first launch SOHO Notes or SOHO Contacts, a personal database will be created on your computer. 
Each subsequent time you launch either product, you’ll automatically be connected to the personal database. 
This database is used to store your personal notes and contacts. Other users will not have access to your personal 
database, nor can you grant them access.

A shared database, on the other hand, is a database where multiple users can share calendar, contact, and note 
information depending on which SOHO series products are being used. This section will provide you, the end 
user, with the necessary information to connect to a shared database.

Database Manager

The Database Manager is where you will open and close shared databases, take shared databases online/offline, 
and change your account password in a shared database. The following sections will discuss each of these tasks 
in detail.

To access the Database Manager for end users:

1. Open SOHO Calendars.

2. Choose File > Manage Databases. The Database Manager window will appear.

3. Click the User button.

Open/Close Shared Databases

This section will show you how to open and close a shared database.

To open a shared database:

The administrator should have provided you with the following information, so you can open a shared database:

■ Your account name and password.
■ Name of shared database.
■ Server address.
■ Read password. The administrator may or may not have set a read password.

Once you have this information you’re ready to open a shared database.

1. Choose File > Manage Databases and click User.

2. Click the Open button. The Open Database window will appear.

3. Enter or choose the server address, database, user name, and password.

4. Click Connect to open the database. Enter the Read password if your administrator set one and click OK. 
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The database will open and appear in the Connected Databases list of the Database Manager window.

5. Enable Require Login in the Connected Databases list if you want SOHO Calendars to ask you for your 
account information each time you launch SOHO Calendars. Otherwise, SOHO Calendars will securely 
store your account information in your Keychain and will use it to open the shared database automatically.

6. Close the Database Manager window. If you’re running SOHO Notes, the shared database will appear in 
the folder list. If you’re running SOHO Contacts, the shared database will appear in the Group list. If you’re 
running SOHO Calendars, the calendars that you have been given access to will be created on your com-
puter and will be accessible via Apple’s iCal application. 

To close a shared database:

When you close a shared database, SOHO Calendars will not automatically open it the next time you launch 
the software. You will need to re-open the database manually using the instructions in the previous section.

1. Choose File > Manage Databases and click User.

2. Select the database you wish to close in the Connected Databases list.

3. Click the Close button.

To change the password of your user account:

You can change the password of your user account for a shared database. If you wish to change the user name of 
your account, you will need to contact your administrator to do this.

1. Choose File > Manage Databases and click User.

2. Select the shared database you wish to change the password of your user account.

3. Click the Change Password button.

4. Enter in your current password and click OK.

5. Enter in the new password and then enter it again to confirm it.

6. Click the Change Password button.

Online/Offline Shared Databases (Mobile End Users)
If you have a laptop computer, you understand that you can’t always be connected to the shared database on 
your office network. Yet, you still may want to access and make changes to the notes, contacts, and calendars in 
a shared database while you’re away. Now you can, and it’s easy to do. Simply, take the shared database “offline” 
before you disconnect from the office network and then later bring the shared databases “online” after you’ve 
reconnected to the office network.

When you take a shared database offline, a mirror copy of the shared database is copied to your computer. This 

Check the online/offline
status of a database.

Check to require a login
each time you open the
software.

See a list of connected
databases.
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becomes the “offline” shared database. While you’re away from the office, you can access and make changes to 
the offline database. When you return to the office and bring your offline database online again, changes made 
to the offline database on your computer are synchronized with the online database on the network. It’s that easy.

To take a shared database offline:

When a database is taken offline, a mirror copy of the shared database is saved on your computer so you can 
continue to work on it even when you're not connected to the network.

1. Choose File > Manage Databases and click User.

2. Select the database you wish to take offline. The Status column in the Connected Databases list will show 
you whether you’re currently accessing the online or offline version of the shared database.

3. Click Go Offline.

To take a shared database online:

When you bring a database back online, all of your changes are synchronized with the original online shared da-
tabase on the network.

1. Choose File > Manage Databases and click User.

2. Select the database you wish to bring online. The Status column in the Connected Databases list will show 
you whether you’re currently accessing the online or offline version of the shared database.

3. Click Go Online.

Please note that if a modification to a record has been made in both the offline database and the main shared 
database, the modification in the offline database will overwrite the modification in the main shared database.
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List View
Chapter 6

Using SOHO Calendars

The purpose of this chapter is to provide an overview of how SOHO Calendars works and then describe how to 
get it set up for your workgroup.

List View
When you first launch SOHO Calendars the List view will be the first window you see. The List view is used to 
view the calendar information in your personal database and any shared databases. For traditional calendar views, 
you will use Apple’s iCal to view and edit the calendar information.

To sort on a column:

1. Click on the column heading you wish to sort. A blue column heading indicates that the column is being 
sorted on. The arrow in the column heading will indicate whether the column is being sorted in ascending 
or descending order.

2. Hold down the Shift key and select another column to sort on. You can sort up to five different columns.The 
number in the column heading will indicate the order in which the column is being sorted.

To change which calendar(s) is displayed:

The List view shows the current calendar selection in the pop-up menu near the bottom of the view. You can 
choose to view a calendar from your personal database or shared database.

1. Select a calendar from the pop-up menu.

Choose which calendar
to display.

Sort on any column.

Quickly switch to a
different SOHO application.

Edit events and tasks using
one of iCal’s calendar views.

Create new events and tasks.

Double-click an
event or task to edit
it.
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To add an event or task to a calendar:

1. Select a calendar from the pop-up menu.

2. Choose File > New Event or File > New Task. The new event window or new task window will appear.

3. Enter the details of your event or task and close the window.

To edit an event or task:

1. Double-click the event or task you wish to edit. The new event window or new task window will appear.

2. Enter the new details of your event or task and close the window.

To delete an event or task:

1. Select the event or task you wish to delete.

2. Choose Edit > Delete.

Overview
SOHO Calendars makes it easy to share calendars between members of your workgroup. SOHO Calendars 
works by setting up a shared database on a server and creating some shared calendars in that database. Each user 
in the workgroup can then connect to the shared database. The shared calendars will automatically appear in iCal 
on each user’s computer. Users can make changes to the shared calendars in iCal and the changes will automat-
ically synchronize to the shared database on the server so all workgroup members receive the changes.

An unlimited number of shared calendars can be created in a shared database. Further, different users in the 
shared database can be given different levels of access (none, read-only, full read/write) to the calendars. For ex-
ample, Susan can be assigned full read/write access while John is given read-only access to a particular calendar.

Setup (for Administrators)
The administrator should follow the below steps after installing SOHO Calendars on the server computer. For 
more information on installing SOHO Calendars, see Installation in Chapter Installation on page 7.

1. Create a shared database on the server. For more information on creating a shared database see Get Started 
(Multi-user Environment) in Chapter Get Started (Multi-user Environment) on page 11.

2. Set up a user account for each user who will be accessing the shared calendars. For more information on 
creating user accounts see Set up User Accounts in Chapter Get Started (Multi-user Environment) on page 14.

3. Create one or more shared calendars and assign access privileges to each calendar. For more information on 
creating calendars and assigning access privileges see Assign Access Privileges in Chapter Get Started (Multi-
user Environment) on page 15.

4. Distribute connection information to each user in your workgroup. For more information on what infor-
mation should be distributed see Distribute Information to End Users in Chapter Get Started (Multi-user En-
vironment) on page 17.

Setup (for End-Users)
Once the administrator has given you the information you need to connect to the shared calendar database, fol-
low the below steps:

1. Launch SOHO Calendars.

2. Connect to the shared database using the information the administrator gave you. For information on con-
necting to a shared database see Connect to a Shared Database (End Users) in Chapter Get Started (Multi-user 
Environment) on page 19.
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SOHO Calendars is now setup to automatically connect to the shared calendars. For all intents and purposes, 
you can now quit SOHO Calendars and only relaunch it if you need to connect to a different shared database. 
From this point forward, you will be accessing the shared calendars using iCal.

3. Launch iCal.

4. Look for the shared calendars to appear in iCal. This may initially take anywhere from a few seconds to a 
few minutes.

5. Add, modify, or delete events in the shared calendar. Your changes will automatically synchronize with the 
shared database server so other users will see your changes.

iCal Basics
You can use Apple’s iCal to view and edit calendar information in your personal database and any shared data-
bases you have been given access to. This section will discuss the very basics of using iCal. For detailed informa-
tion on using iCal please visit http://www.apple.com or consult iCal help (open iCal and choose Help > iCal 
Help). 

Calendars

The shared calendars you have been given access to will appear in the main calendar list in iCal. These calendars 
will work just like any other calendar you have in iCal. For example, you can use the Publish feature in iCal to 
publish a shared calendar to a web site. You can also use iSync to sync shared calendars to a Palm handheld or 
cell phone. 

Events and To-Do’s

Events and To Do’s can be created, modified, or deleted in a shared calendar just like any other calendar.

To create an event or To Do:

1. Choose File > New Event or New To Do.

2. Type a title for the event or To Do.

3. Make any other changes to the event or To Do (i.e. assigning an alarm or a due date).

To delete an event or To Do:

1. Select the event or To Do you wish to delete.

2. Choose Edit > Delete.

Shared calendars will be listed
in the main calendar list in iCal.
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Synchronization Helper Applications
Chapter 7

Universal Synchronization

The personal database on your computer may contain notes, contacts, and calendars that were created by SOHO 
Notes, SOHO Contacts, or SOHO Calendars depending upon which SOHO series products you own. The in-
formation in your personal database can be synchronized to other applications (Apple’s Address Book, Apple’s 
iCal, etc.) and/or devices (cell phones, P.D.A.’s, etc.) attached to your computer. This means, for example, that 
your contacts in SOHO Contacts will automatically synchronize and appear in Apple’s Address Book application 
and on your cell phone. Your information will thus become universally available on your computer and devices. 
This universal synchronization uses and requires the synchronization technology built-in to Mac OS X 10.4 and 
later.

Any application, device, or computer that supports synchronization technology built-in to Mac OS X 10.4 will 
be able to synchronize with the notes, contacts, and calendars in your personal database. If you have an Apple 
.Mac account (must be purchased separately), you can even synchronization your notes, contacts, and calendars 
between multiple computers.

This chapter will describe how synchronization works, explain what happens during your first synchronization, 
detail how to synchronize your data between multiple computers, and cover how to synchronize your informa-
tion with cell phone and P.D.A. devices.

Synchronization Helper Applications
The SOHO Series products use two background helper applications called SOHO Sync and ChronosCalen-
darsService to synchronize the information in your personal database. Each of these applications are automati-
cally launched whenever its services are needed and automatically quits when it’s finished. This means you do 
not need to worry about manually running either. We mention these applications in case you see them running 
and wonder what they are.

■ SOHO Sync. This application works in conjunction with Sync Services (part of Mac OS X) to keep your 
notes, contacts, and calendars synchronized.

■ ChronosCalendarsService. This application helps ensure shared databases remain synchronized with iCal.

Your First Synchronization
The first time SOHO Sync runs, three Sync Alert windows will appear: one for notes, one for contacts, and one 
for calendars. This section will describe the choices these alerts present so you can respond accordingly.
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Sync Alert for Notes

To respond to the Sync Alert window for Notes:
■ Delete all notes from SOHO Sync before syncing. This option will only take affect if you click the Allow 

button. If you enable this option, all the notes in your personal database will be deleted prior to synchroniz-
ing notes from Apple’s .Mac. If you don’t enable this option, the notes in your personal database will be 
merged with notes on Apple’s .Mac.

■ Allow. If you click Allow, your notes will be synchronized based on what you chose for the “Delete all notes 
from SOHO Sync before syncing” option. The Allow option is the preferable choice.

■ Don’t Allow. If you click Don’t Allow, then notes in your personal database will not be synchronized at this 
time and this alert will reappear during the next synchronization session.

Sync Alert for Contacts

To respond to the Sync Alert window for Contacts:
■ Delete all contacts from SOHO Sync before syncing. This option will only take affect if you click the Allow 

button. If you enable this option, all the contacts in your personal database will be deleted prior to synchro-
nizing contacts from other applications such as the Apple’s Address Book. If you don’t enable this option, 
the contacts in your personal database will be merged with contacts in other applications and devices on your 
computer.

■ Allow. If you click Allow, your contacts will be synchronized based on what you choose for the “Delete all 
contacts from SOHO Sync before syncing” option. The Allow option is the preferable choice.

■ Don’t Allow. If you click Don’t Allow, then contacts in your personal database will not be synchronized at 
this time and this alert will reappear during the next synchronization session.
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Sync Alert for Calendars

To respond to the Sync Alert window for Calendars:
■ Delete all calendars from SOHO Sync before syncing. This option will only take affect if you click the Al-

low button. If you enable this option, all the calendars in your personal database will be deleted prior to syn-
chronizing calendars from other applications such as the Apple’s iCal. If you don’t enable this option, the 
calendars in your personal database will be merged with calendars in other applications and devices on your 
computer.

■ Allow. If you click Allow, your calendars will be synchronized based on what you choose for the “Delete all 
contacts from SOHO Sync before syncing” option. The Allow option is the preferable choice.

■ Don’t Allow. If you click Don’t Allow, then calendars in your personal database will not be synchronized 
at this time and this alert will reappear during the next synchronization session.

.Mac Synchronization
The synchronization technology in Mac OS 10.4 and later will even let you synchronize your notes, calendars, 
and contacts between multiple computers using an Apple .Mac account (must be purchased separately). In order 
to use the .Mac sync feature, you will need a .Mac account from Apple. For more information on obtaining a 
.Mac account see http://www.chronosnet.com/dotmacaccount.html.

To set up a SOHO series product to synchronize with .Mac:

1. Open the System Preferences and click the .Mac button.

2. Click the Sync tab.

3. Choose how often you want your information synchronized to your .Mac account. You may want to base 
your choice on the speed of your Internet connection and how often you need your information kept up to 
date. There are even options to only synchronize when you manually tell it to or automatically whenever the 
system determines it needs to.

4. Enable Notes, Contacts, and Calendars in the list depending on what information you want synchronized 
with .Mac. This means you can synchronize contacts to your .Mac account, but not notes and calendars.

To reset the data in your personal database with .Mac data or vice versa:

If you want to replace the data in your database with the data in your .Mac account, or vice versa, follow the 
below steps:

1. Open the System Preferences and click the .Mac button.

2. Click the Advanced tab.

3. Click Reset Sync Data.

4. Choose the data you want to reset.

5. Choose whether you want to replace the data on your computer with sync info from .Mac or vice versa.

6. Click Replace.
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P.D.A. and Phone Synchronization
P.D.A. and Phone Synchronization
The calendar and contact information in your personal database can not only be synchronized with other appli-
cations like Apple’s Address Book or iCal, but can also be synchronized with your cell phone or P.D.A. using 
Apple’s iSync. For more information on which devices iSync supports and how to use iSync, please visit http://
www.apple.com.

iPod Synchronization
The calendar and contact information in your personal database can be synchronized to your iPod using Apple’s 
iTunes. For more information on synchronizing calendar and contact information to an iPod, please visit http:/
/www.apple.com.
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